summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksey Filippov2013-10-19 09:13:16 +0400
committerAleksey Filippov2013-10-19 09:13:16 +0400
commite586a6b2c8dc5c9f7215e6aa6f920d3ba6069de6 (patch)
tree217f7dd2ba9a7d69dbf50421797c4f4a55336877
downloadaur-e586a6b2c8dc5c9f7215e6aa6f920d3ba6069de6.tar.gz
obnam package update.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a204cfbb4e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-tracing-git
+ pkgdesc = The Python library tracing helps with logging debug messages.
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = http://liw.fi/tracing/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = python2
+ provides = python2-tracing
+ conflicts = python2-tracing
+ replaces = python2-tracing-bzr
+ source = python2-tracing-git::git://git.liw.fi/python-tracing
+ md5sums = SKIP
+
+pkgname = python2-tracing-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..991698aa2c02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Aleksey Filippov <sarum9in@gmail.com>
+pkgname=python2-tracing-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="The Python library tracing helps with logging debug messages."
+arch=('i686' 'x86_64')
+url="http://liw.fi/tracing/"
+license=('GPL3')
+groups=()
+depends=('python2')
+makedepends=('git')
+provides=('python2-tracing')
+conflicts=('python2-tracing')
+replaces=('python2-tracing-bzr')
+backup=()
+options=()
+install=
+source=("$pkgname::git://git.liw.fi/python-tracing")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ find . -type f -exec sed -ri "s|^#!/usr/bin/python$|&2|g" '{}' '+'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: