summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commitdd8686a2330be1e6d2f3ad3707402447b15c1837 (patch)
tree940cb19d17f1c0f5439d4f2936538973b8ec4b72
downloadaur-dd8686a2330be1e6d2f3ad3707402447b15c1837.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1ef04fdd9a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-translitcodec
+ pkgdesc = Unicode to 8-bit charset transliteration codec
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/claudep/translitcodec
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/t/translitcodec/translitcodec-0.4.0.tar.gz
+ md5sums = 7fd31bd3f792982a7919ab131ac848cf
+ sha256sums = 715a8995f84482cd23c1b02fd254ff4da66589e9d5222de10f7efe49d7bea683
+
+pkgname = python2-translitcodec
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5718271a9ad1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Dennis Fink <the_metalgamer@hackerspace.lu>
+
+pkgname=python2-translitcodec
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Unicode to 8-bit charset transliteration codec"
+arch=('any')
+depends=('python2')
+makedepends=('python2-setuptools')
+url="https://github.com/claudep/translitcodec"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/t/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('7fd31bd3f792982a7919ab131ac848cf')
+sha256sums=('715a8995f84482cd23c1b02fd254ff4da66589e9d5222de10f7efe49d7bea683')
+
+build() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}