summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2015-06-20 09:14:43 -0700
committerEric Anderson2015-06-20 09:14:43 -0700
commita68badde7139ce667330888a79f0ff12b46e979c (patch)
treee39b2c5b20344ce3b4d14a24b9ab63823dd0efbd
downloadaur-a68badde7139ce667330888a79f0ff12b46e979c.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9807d478aa17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-ttystatus
+ pkgdesc = Library for showing progress reporting and status updates on terminals
+ pkgver = 0.23
+ pkgrel = 2
+ url = http://liw.fi/ttystatus/
+ arch = any
+ license = GPL3
+ depends = python2
+ source = http://code.liw.fi/debian/pool/main/p/python-ttystatus/python-ttystatus_0.23.orig.tar.gz
+ sha256sums = 1ecd58dff0049fdccedb6cd41ff0ddc51971c943e8d1887f8c027ae9e3aeb17a
+
+pkgname = python2-ttystatus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9440620914e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Mathieu Clabaut <mathieu.clabaut@gmail.com>
+# Maintainer: Eric Anderson <ejona86@gmail.com>
+
+pkgname=python2-ttystatus
+pkgver=0.23
+pkgrel=2
+pkgdesc="Library for showing progress reporting and status updates on terminals"
+arch=('any')
+url="http://liw.fi/ttystatus/"
+license=('GPL3')
+depends=('python2')
+source=("http://code.liw.fi/debian/pool/main/p/python-ttystatus/python-ttystatus_$pkgver.orig.tar.gz")
+sha256sums=('1ecd58dff0049fdccedb6cd41ff0ddc51971c943e8d1887f8c027ae9e3aeb17a')
+
+build() {
+ cd "$srcdir/ttystatus-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/ttystatus-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}