summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrygve Aaberge2015-07-07 02:18:25 +0200
committerTrygve Aaberge2015-07-07 02:18:25 +0200
commitccaa2b0c0be13c85f2b7ac3697dc2f02b675a72e (patch)
treec6f3f9f70334ecd2ec7d39272f6614e696ebaca9
downloadaur-ccaa2b0c0be13c85f2b7ac3697dc2f02b675a72e.tar.gz
Initial import, version 0.1.3-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e4996a3011d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-tunigo
+ pkgdesc = Python API for the browse feature of Spotify
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/trygveaa/python-tunigo
+ arch = any
+ license = APACHE
+ makedepends = python2
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-requests
+ source = https://pypi.python.org/packages/source/t/tunigo/tunigo-0.1.3.tar.gz
+ md5sums = a8724b6964d76782cb7156a8b713fdce
+
+pkgname = python2-tunigo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d048616b84a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Trygve Aaberge <trygveaa+aur at gmail dot com>
+
+pkgname=python2-tunigo
+_pypiname=tunigo
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Python API for the browse feature of Spotify"
+arch=('any')
+url="https://github.com/trygveaa/python-tunigo"
+license=('APACHE')
+depends=('python2' 'python2-requests')
+makedepends=('python2' 'python2-setuptools')
+source=("https://pypi.python.org/packages/source/t/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+md5sums=('a8724b6964d76782cb7156a8b713fdce')
+
+package() {
+ cd "${srcdir}/${_pypiname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: