summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2015-08-02 17:11:34 +0200
committerSébastien Leduc2015-08-02 17:11:34 +0200
commitcb307d983735beff598b938e9cf87bbf66f438ec (patch)
treec0c60cecc041124f2b37dcf14d8ef8c95d7d805c
downloadaur-cb307d983735beff598b938e9cf87bbf66f438ec.tar.gz
Initial commit for python2-tvrage
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c2a226b2762
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-tvrage
+ pkgdesc = Object oriented client interface for tvrage.com's XML based api feeds
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/python-tvrage
+ arch = any
+ license = GPL
+ makedepends = python2-distribute
+ depends = python2
+ source = http://pypi.python.org/packages/source/p/python-tvrage/python-tvrage-0.4.1.tar.gz
+ md5sums = cdfec252158c5047b626861900186dfb
+
+pkgname = python2-tvrage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee6511b2da42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: sleduc <sebastien@sleduc.fr>
+# Contributor: shadyabhi <abhijeet.1989@gmail.com>
+# Author : Christian Kreutzer
+
+pkgname=python2-tvrage
+_realname=python-tvrage
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Object oriented client interface for tvrage.com's XML based api feeds"
+url="https://pypi.python.org/pypi/python-tvrage"
+arch=('any')
+license=('GPL')
+depends=('python2')
+makedepends=('python2-distribute')
+source=("http://pypi.python.org/packages/source/p/$_realname/$_realname-$pkgver.tar.gz")
+md5sums=('cdfec252158c5047b626861900186dfb')
+
+package(){
+ #Really ugly, but what can be done.
+ cd "$srcdir/ckreutzer-python-tvrage-c8e9781"
+
+ # python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}