summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilles Hamel2016-01-31 22:22:46 +0100
committerGilles Hamel2016-01-31 22:22:46 +0100
commit5729dcf9e7c61879b29aa413d80d61e79ed6cdc8 (patch)
tree3d5be157f5ff7e08a9651f21d4b7b09dc443ffbf
downloadaur-5729dcf9e7c61879b29aa413d80d61e79ed6cdc8.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a9d96981ab2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jan 31 21:22:06 UTC 2016
+pkgbase = python2-txamqp
+ pkgdesc = Python library for communicating with AMQP peers and brokers using Twisted
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://launchpad.net/txamqp
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ depends = twisted
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/t/txAMQP/txAMQP-0.6.2.tar.gz
+ md5sums = 8c3e9c42d60d06b088d91ed9ba159e13
+
+pkgname = python2-txamqp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13656b0fcec9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+Maintainer='Gilles Hamel <hamelg@laposte.net>'
+pkgname=python2-txamqp
+pkgver=0.6.2
+pkgrel=1
+pkgdesc='Python library for communicating with AMQP peers and brokers using Twisted'
+arch=('any')
+url='https://launchpad.net/txamqp'
+license=('Apache')
+groups=()
+depends=('python2' 'twisted')
+makedepends=('python2-setuptools')
+options=(!emptydirs)
+source=('https://pypi.python.org/packages/source/t/txAMQP/txAMQP-0.6.2.tar.gz')
+md5sums=('8c3e9c42d60d06b088d91ed9ba159e13')
+
+package() {
+ cd "$srcdir/txAMQP-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file