summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2017-10-25 20:59:59 +0200
committerjnanar2017-10-25 20:59:59 +0200
commit18f53f95db77fe770afe23a3a490de79ceab8925 (patch)
tree95a01f80ab025a2fc2ddf9d1ff9ba736e42113ab
downloadaur-18f53f95db77fe770afe23a3a490de79ceab8925.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed2868d7ebf1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-txjsonrpc-git
+ pkgdesc = txJSON-RPC allows you to create async Python JSON-RPC servers and clients either over HTTP or directly on TCP with the Netstring protocol. txJSON-RPC is written in Twisted.
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/oubiwann/txjsonrpc
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2
+ options = !emptydirs
+ source = git+https://github.com/oubiwann/txjsonrpc.git
+ md5sums = SKIP
+
+pkgname = python2-txjsonrpc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b851186df9a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+#Maintainer: jnanar <info@agayon.be>
+
+pkgname=python2-txjsonrpc-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="txJSON-RPC allows you to create async Python JSON-RPC servers and clients either over HTTP or directly on TCP with the Netstring protocol. txJSON-RPC is written in Twisted."
+arch=(any)
+url="https://github.com/oubiwann/txjsonrpc"
+license=('MIT')
+depends=('python2')
+makedepends=('git')
+options=(!emptydirs)
+#optdepends=('')
+
+source=('git+https://github.com/oubiwann/txjsonrpc.git')
+_gitname="txjsonrpc"
+
+md5sums=('SKIP')
+
+
+#pkgver() {
+# cd $_gitname
+# git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+#}
+
+
+package() {
+
+ cd "$srcdir/$_gitname"
+
+ # make sure UNICODE characters in the README are parsed correctly
+ export LC_CTYPE=en_US.utf-8
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}