summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2018-06-07 21:50:38 +0200
committerjnanar2018-06-07 21:50:38 +0200
commit4ca923b302aaa80ced840c56b9de9942c65d102d (patch)
treefb2707a35fff12093c9b4e48d607a81034fb1f02
parent18f53f95db77fe770afe23a3a490de79ceab8925 (diff)
downloadaur-4ca923b302aaa80ced840c56b9de9942c65d102d.tar.gz
Small fix PKGBUILD
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b851186df9a9..0983052f3f7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
#Maintainer: jnanar <info@agayon.be>
pkgname=python2-txjsonrpc-git
-pkgver=0.0.1
+pkgver=0.3.1.r20160319.5b7c241.
+_version=0.3.1
pkgrel=1
pkgdesc="txJSON-RPC allows you to create async Python JSON-RPC servers and clients either over HTTP or directly on TCP with the Netstring protocol. txJSON-RPC is written in Twisted."
arch=(any)
@@ -11,24 +12,18 @@ depends=('python2')
makedepends=('git')
options=(!emptydirs)
#optdepends=('')
-
source=('git+https://github.com/oubiwann/txjsonrpc.git')
_gitname="txjsonrpc"
-
md5sums=('SKIP')
+pkgver() {
+ cd $_gitname
+ printf "$_version.r%s.%s" "$(git log -1 --format=%cd.%h --date=short|tr -d -)"
-#pkgver() {
-# cd $_gitname
-# git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-#}
-
+}
package() {
cd "$srcdir/$_gitname"
-
- # make sure UNICODE characters in the README are parsed correctly
- export LC_CTYPE=en_US.utf-8
python2 setup.py install --root="$pkgdir/" --optimize=1
}