summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrito2015-09-04 19:18:36 +0200
committercrito2015-09-04 19:18:36 +0200
commitc437e43d9aadcbd50a667a051ba89a589fe82ae6 (patch)
tree2063fc8d129cf8d2e3fdd32465596dd7acd08f05
downloadaur-c437e43d9aadcbd50a667a051ba89a589fe82ae6.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c04e69d33b2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-txzmq
+ pkgdesc = ZeroMQ bindings for Twisted.
+ pkgver = 0.7.4
+ pkgrel = 1
+ url = https://github.com/smira/txZMQ
+ arch = any
+ license = GPL2
+ makedepends = python2-sphinx
+ makedepends = make
+ depends = python2>=2.7
+ depends = zeromq
+ depends = python2-pyzmq>=13.0
+ depends = python2-twisted>=10.0
+ source = https://github.com/smira/txZMQ/archive/0.7.4.tar.gz
+ md5sums = b95ee236c1b6253006170be81fcee2d7
+
+pkgname = python2-txzmq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38f3223c116f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: crito <crito@cryptodrunks.net>
+pkgname=python2-txzmq
+pkgver=0.7.4
+pkgrel=1
+pkgdesc="ZeroMQ bindings for Twisted."
+arch=('any')
+url="https://github.com/smira/txZMQ"
+license=('GPL2')
+depends=('python2>=2.7' 'zeromq' 'python2-pyzmq>=13.0' 'python2-twisted>=10.0')
+makedepends=('python2-sphinx' 'make')
+source=("https://github.com/smira/txZMQ/archive/${pkgver}.tar.gz")
+md5sums=('b95ee236c1b6253006170be81fcee2d7')
+
+package() {
+ cd "${srcdir}/txZMQ-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 AUTHORS.txt "${pkgdir}/usr/share/doc/${pkgname}/AUTHORS"
+ install -Dm644 VERSION "${pkgdir}/usr/share/doc/${pkgname}/VERSION"
+ install -Dm644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+
+ # Build the docs as well - Fails now because two doctests fail
+ cd "${srcdir}/txZMQ-${pkgver}/docs"
+ make SPHINXBUILD=/usr/bin/sphinx-build2 html
+ install -Ddm755 _build/html "${pkgdir}/usr/share/doc/${pkgname}/html"
+}
+
+# vim:set ts=2 sw=2 et: