summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVisa Jokelainen2017-07-20 14:49:09 +0300
committerVisa Jokelainen2017-07-20 14:52:53 +0300
commit5dc266d9779b4121e2c19ad9c66d56db0fe356d8 (patch)
treed432ef1d96d300a8966cfaf83870c76d9a692a24
downloadaur-5dc266d9779b4121e2c19ad9c66d56db0fe356d8.tar.gz
Initial commit, ubjson 0.9.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc9fa7722c91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-ubjson
+ pkgdesc = Universal Binary JSON encoder/decoder
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/py-ubjson/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/d4/40/a80006884ec03a54a5c6c53ae76df9978536862f0683b6e6280e3808d289/py-ubjson-0.9.0.tar.gz
+ md5sums = c78bbe899eeba9604302ad746094e8d1
+
+pkgname = python2-ubjson
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..859a18ddbad4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Visa Jokelainen <visaj at iki dot fi>
+_pkgname=py-ubjson
+pkgname=python2-ubjson
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Universal Binary JSON encoder/decoder"
+arch=('i686' 'x86_64')
+url="https://pypi.python.org/pypi/py-ubjson/"
+license=('Apache')
+groups=()
+depends=('python2')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://pypi.python.org/packages/d4/40/a80006884ec03a54a5c6c53ae76df9978536862f0683b6e6280e3808d289/$_pkgname-${pkgver}.tar.gz")
+md5sums=(c78bbe899eeba9604302ad746094e8d1)
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: