summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-09-22 13:58:22 +0200
committerGoliathLabs2020-09-22 13:58:22 +0200
commitff469f1d2564f0716570e8f0fa2933d56744f717 (patch)
tree47181bcefb609b3bfb7246019279e16853d81d53
parent8eac37d27e3e5766b69c7e0628862372bc2fd85b (diff)
downloadaur-ff469f1d2564f0716570e8f0fa2933d56744f717.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08431a1fb017..4a15921dcb21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python2-urwid
pkgdesc = Curses-based user interface library
pkgver = 2.1.1
- pkgrel = 2
+ pkgrel = 3
url = http://excess.org/urwid/
arch = x86_64
license = LGPL
makedepends = glibc
makedepends = python2-setuptools
makedepends = python2-mock
+ makedepends = python-tox
depends = python2
depends = glibc
source = https://github.com/urwid/urwid/archive/release-2.1.1/python2-urwid-2.1.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index f7f3a9635eb1..31a8c76a42fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@
pkgname=python2-urwid
pkgver=2.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='Curses-based user interface library'
url='http://excess.org/urwid/'
arch=('x86_64')
license=('LGPL')
depends=('python2' 'glibc')
-makedepends=('glibc' 'python2-setuptools' 'python2-mock')
+makedepends=('glibc' 'python2-setuptools' 'python2-mock' 'python-tox')
source=(https://github.com/urwid/urwid/archive/release-${pkgver}/${pkgname}-${pkgver}.tar.gz)
sha256sums=('06fc11e62083f0de2ae8525d278bd5ca7f06bcf10773e299812ab5f617f8bd50')
sha512sums=('6ab861c02edff37e31b1a5b138e71abf978f8ef9a54e0993b740ec62c0986ce1e25c2421a4a4b0d428a8cd64970496b23790074c911b6e4990b3d821a3bf2b4c')
@@ -26,7 +26,7 @@ build() {
check() {
(cd urwid-release-${pkgver}
- python2 setup.py test
+ tox -e py27
)
}