summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfab2017-01-10 17:07:48 +0100
committerfab2017-01-10 17:07:48 +0100
commit3847b16f28a1aebeab57f8679a9352946f78ac8a (patch)
treec65a995abdae7a442c869b17a237092aeb9bfb56
downloadaur-3847b16f28a1aebeab57f8679a9352946f78ac8a.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44bd47a8b40d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-usbrevue
+ pkgdesc = USB Reverse-Engineering Toolkit
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://bitbucket.org/TeamC2011/usbrevue/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = python2
+ depends = scapy
+ depends = python2-pcapy
+ depends = python2-gflags
+ options = !emptydirs
+ source = https://github.com/fdev31/usbrevue/archive/fb01f124513c5e49ff0f8b77939c6dcf39e7b90c.zip
+ md5sums = 6557d2095ca8348b601bfb4f9fe4eeb3
+
+pkgname = python2-usbrevue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..075f2f074727
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/Python_Package_Guidelines for more
+# information on Python packaging.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=python2-usbrevue
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="USB Reverse-Engineering Toolkit"
+arch=(i686 x86_64)
+url="https://bitbucket.org/TeamC2011/usbrevue/"
+license=('unknown')
+groups=()
+depends=('python2' 'scapy' 'python2-pcapy' 'python2-gflags')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=('https://github.com/fdev31/usbrevue/archive/fb01f124513c5e49ff0f8b77939c6dcf39e7b90c.zip')
+md5sums=('6557d2095ca8348b601bfb4f9fe4eeb3')
+
+package() {
+ cd "$srcdir/usbrevue-"*
+ sed -i "s/env python/env python2/g" *.py
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: