summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit14d6656c714d59f707c31f041c46b24de43e8ea0 (patch)
treed276fadfad4f85fc99ca907f9ca3d6ac3dd6ab34
downloadaur-14d6656c714d59f707c31f041c46b24de43e8ea0.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43170a609908
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-verlib
+ pkgdesc = A new version comparison tool for distutils
+ pkgver = 0.1
+ pkgrel = 2
+ url = https://pypi.python.org/pypi/verlib
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/v/verlib/verlib-0.1.tar.gz
+ md5sums = 1cdf84a3e5334558e428b4067f586e7b
+ sha256sums = 652d097d114dc9076606a5416b0dc193df3ef2632596e6e0e9d21d2ba51bf267
+
+pkgname = python2-verlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0030a1cdebe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-verlib
+pkgver=0.1
+pkgrel=2
+pkgdesc="A new version comparison tool for distutils"
+arch=('i686' 'x86_64')
+depends=('python2')
+makedepends=('python2-setuptools')
+url="https://pypi.python.org/pypi/verlib"
+license=('Apache')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/v/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('1cdf84a3e5334558e428b4067f586e7b')
+sha256sums=('652d097d114dc9076606a5416b0dc193df3ef2632596e6e0e9d21d2ba51bf267')
+
+build() {
+ cd $srcdir/${pkgname#python2-}-$pkgver
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/${pkgname#python2-}-$pkgver
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}