summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-07-21 01:13:36 +0000
committerDaniel Bermond2018-07-21 01:13:36 +0000
commit2a6ccc6cc848a824bc63b2bdb1b48886405b087f (patch)
treeba54706df6841c0af674aaaf6548642c1fb85ce9
parent72094204bd6e0958d15b2b8ee261c24c1982cbfa (diff)
downloadaur-2a6ccc6cc848a824bc63b2bdb1b48886405b087f.tar.gz
Updated to version 1.3.7
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75e99c306674..c6b024b65d8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python2-vmaf
pkgdesc = Perceptual video quality assessment algorithm based on multi-method fusion (python2 implementation)
- pkgver = 1.3.5
+ pkgver = 1.3.7
pkgrel = 1
url = https://github.com/netflix/vmaf/
arch = any
license = APACHE
+ makedepends = git
makedepends = python2
makedepends = python2-setuptools
depends = python2
@@ -14,11 +15,11 @@ pkgbase = python2-vmaf
depends = python2-pandas
depends = python2-scikit-learn
depends = python2-h5py
- depends = libsvm
+ depends = python2-scikit-image
conflicts = python2-vmaf-git
- source = vmaf-1.3.5.tar.gz::https://github.com/Netflix/vmaf/archive/v1.3.5.tar.gz
- source = vmaf-submodule-sureal::git+https://github.com/Netflix/sureal.git#commit=c97c1bede576f18589e07d6be251bef4f6ba3532
- sha256sums = 28ff05935889147a6dedb2089be918f0ce903e4a386091274be5ad3118b2950d
+ source = vmaf-1.3.7.tar.gz::https://github.com/Netflix/vmaf/archive/v1.3.7.tar.gz
+ source = vmaf-submodule-sureal::git+https://github.com/Netflix/sureal.git#commit=90683ac5cc79e99f29806c864b1237b4397520d2
+ sha256sums = 124e7ec03de83f4051f9d6210824f5ca083c7dac9fcf6ed12d196f98849c5d0d
sha256sums = SKIP
pkgname = python2-vmaf
diff --git a/PKGBUILD b/PKGBUILD
index 5e67e4922fb0..478260e6b601 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
_srcname=vmaf
-_sureal_commit='c97c1bede576f18589e07d6be251bef4f6ba3532'
+_sureal_commit='90683ac5cc79e99f29806c864b1237b4397520d2'
pkgname=python2-vmaf
-pkgver=1.3.5
+pkgver=1.3.7
pkgrel=1
pkgdesc='Perceptual video quality assessment algorithm based on multi-method fusion (python2 implementation)'
arch=('any')
@@ -15,13 +15,13 @@ depends=(
'python2' 'python2-numpy' 'python2-scipy' 'python2-matplotlib'
'python2-pandas' 'python2-scikit-learn' 'python2-h5py'
# AUR:
- 'libsvm'
+ 'python2-scikit-image'
)
-makedepends=('python2' 'python2-setuptools')
+makedepends=('git' 'python2' 'python2-setuptools')
conflicts=('python2-vmaf-git')
source=("${_srcname}-${pkgver}.tar.gz"::"https://github.com/Netflix/${_srcname}/archive/v${pkgver}.tar.gz"
'vmaf-submodule-sureal'::"git+https://github.com/Netflix/sureal.git#commit=${_sureal_commit}")
-sha256sums=('28ff05935889147a6dedb2089be918f0ce903e4a386091274be5ad3118b2950d'
+sha256sums=('124e7ec03de83f4051f9d6210824f5ca083c7dac9fcf6ed12d196f98849c5d0d'
'SKIP')
prepare() {
@@ -47,19 +47,19 @@ package() {
# vmaf python2 executables
cd script
- executables=($(find . -type f -executable))
- for _script in ${executables[@]}
+ local _executables=($(find . -type f -executable))
+ for _script in ${_executables[@]}
do
- install -D -m755 "$_script" "${pkgdir}/usr/bin/${_script}"
+ install -D -m755 "$_script" -t "${pkgdir}/usr/bin"
done
# sureal python2 executable
cd "${srcdir}/${_srcname}-${pkgver}/sureal/python/script"
- install -D -m755 run_subj.py "${pkgdir}/usr/bin/run_subj.py"
+ install -D -m755 run_subj.py -t "${pkgdir}/usr/bin"
# sureal python2 modules
cd "${srcdir}/${_srcname}-${pkgver}/sureal/python/src"
- cp -a sureal "${pkgdir}/usr/lib/python2.7/site-packages"
+ cp -af sureal "${pkgdir}/usr/lib/python2.7/site-packages"
# fix shebang on python2 scripts
for _script in "$pkgdir"/usr/bin/*