summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-08-10 20:08:49 +0000
committerDaniel Bermond2018-08-10 20:08:49 +0000
commit48c582113afcb479500270265789563ce0f83d42 (patch)
tree54d5916f23727ec9e657f30ec91511529e2653aa
parent2a6ccc6cc848a824bc63b2bdb1b48886405b087f (diff)
downloadaur-48c582113afcb479500270265789563ce0f83d42.tar.gz
Updated to version 1.3.9
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6b024b65d8d..50a2dc32f923 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = python2-vmaf
pkgdesc = Perceptual video quality assessment algorithm based on multi-method fusion (python2 implementation)
- pkgver = 1.3.7
+ pkgver = 1.3.9
pkgrel = 1
url = https://github.com/netflix/vmaf/
arch = any
license = APACHE
makedepends = git
- makedepends = python2
makedepends = python2-setuptools
depends = python2
depends = python2-numpy
@@ -17,9 +16,9 @@ pkgbase = python2-vmaf
depends = python2-h5py
depends = python2-scikit-image
conflicts = python2-vmaf-git
- source = vmaf-1.3.7.tar.gz::https://github.com/Netflix/vmaf/archive/v1.3.7.tar.gz
- source = vmaf-submodule-sureal::git+https://github.com/Netflix/sureal.git#commit=90683ac5cc79e99f29806c864b1237b4397520d2
- sha256sums = 124e7ec03de83f4051f9d6210824f5ca083c7dac9fcf6ed12d196f98849c5d0d
+ source = vmaf-1.3.9.tar.gz::https://github.com/Netflix/vmaf/archive/v1.3.9.tar.gz
+ source = vmaf-submodule-sureal::git+https://github.com/Netflix/sureal.git#commit=4d0fee6e83047da53ff1776a883579bfe101e8ea
+ sha256sums = c9e4fc850f66cf959a36c9603cef26c4298eec20d6c26f9482a355c5753c092d
sha256sums = SKIP
pkgname = python2-vmaf
diff --git a/PKGBUILD b/PKGBUILD
index 478260e6b601..92d85e973aee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
_srcname=vmaf
-_sureal_commit='90683ac5cc79e99f29806c864b1237b4397520d2'
+_sureal_commit='4d0fee6e83047da53ff1776a883579bfe101e8ea'
pkgname=python2-vmaf
-pkgver=1.3.7
+pkgver=1.3.9
pkgrel=1
pkgdesc='Perceptual video quality assessment algorithm based on multi-method fusion (python2 implementation)'
arch=('any')
@@ -17,11 +17,11 @@ depends=(
# AUR:
'python2-scikit-image'
)
-makedepends=('git' 'python2' 'python2-setuptools')
+makedepends=('git' 'python2-setuptools')
conflicts=('python2-vmaf-git')
source=("${_srcname}-${pkgver}.tar.gz"::"https://github.com/Netflix/${_srcname}/archive/v${pkgver}.tar.gz"
'vmaf-submodule-sureal'::"git+https://github.com/Netflix/sureal.git#commit=${_sureal_commit}")
-sha256sums=('124e7ec03de83f4051f9d6210824f5ca083c7dac9fcf6ed12d196f98849c5d0d'
+sha256sums=('c9e4fc850f66cf959a36c9603cef26c4298eec20d6c26f9482a355c5753c092d'
'SKIP')
prepare() {
@@ -39,6 +39,7 @@ build() {
# waiting for upstream to finish python3 support
# https://github.com/Netflix/vmaf/issues/128
+# https://github.com/Netflix/vmaf/blob/a0a4deeb7cd7b6e5cdd7c40398e6ce3c1498a0d8/resource/doc/VMAF_Python_library.md
package() {
cd "${_srcname}-${pkgver}/python"