summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-02-23 22:27:14 +0000
committerDaniel Bermond2019-02-23 22:27:14 +0000
commit8ce61ff98b62f66e6526f48b03c8d70aa8ba0169 (patch)
treea1b6e1a8ec65bd86b579c12c6ce53398b91cee4f
parent960baab5d44b39799e2c3d320789a1668237d809 (diff)
downloadaur-8ce61ff98b62f66e6526f48b03c8d70aa8ba0169.tar.gz
Updated to version 1.3.13
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD45
2 files changed, 17 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7437cb870e0e..0deb6fc0cc29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-vmaf
pkgdesc = Perceptual video quality assessment algorithm based on multi-method fusion (python2 implementation)
- pkgver = 1.3.9
- pkgrel = 3
+ pkgver = 1.3.13
+ pkgrel = 1
url = https://github.com/netflix/vmaf/
arch = any
license = APACHE
@@ -15,10 +15,9 @@ pkgbase = python2-vmaf
depends = python2-scikit-learn
depends = python2-h5py
depends = python2-scikit-image
- source = vmaf-1.3.9.tar.gz::https://github.com/Netflix/vmaf/archive/v1.3.9.tar.gz
- source = vmaf-submodule-sureal::git+https://github.com/Netflix/sureal.git#commit=4d0fee6e83047da53ff1776a883579bfe101e8ea
- sha256sums = c9e4fc850f66cf959a36c9603cef26c4298eec20d6c26f9482a355c5753c092d
- sha256sums = SKIP
+ depends = python2-sureal
+ source = vmaf-1.3.13.tar.gz::https://github.com/Netflix/vmaf/archive/v1.3.13.tar.gz
+ sha256sums = 926ed538c7d7ae3a36064b87a34094a9d2bee20f7e51a64f8bb275f6c44a8ae3
pkgname = python2-vmaf
diff --git a/PKGBUILD b/PKGBUILD
index 709492740dd0..67e2483fe1bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,9 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
-_srcname=vmaf
-_sureal_commit='4d0fee6e83047da53ff1776a883579bfe101e8ea'
-
pkgname=python2-vmaf
-pkgver=1.3.9
-pkgrel=3
+_srcname=vmaf
+pkgver=1.3.13
+pkgrel=1
pkgdesc='Perceptual video quality assessment algorithm based on multi-method fusion (python2 implementation)'
arch=('any')
url='https://github.com/netflix/vmaf/'
@@ -15,20 +13,11 @@ depends=(
'python2' 'python2-numpy' 'python2-scipy' 'python2-matplotlib'
'python2-pandas' 'python2-scikit-learn' 'python2-h5py'
# AUR:
- 'python2-scikit-image'
+ 'python2-scikit-image' 'python2-sureal'
)
makedepends=('git' 'python2-setuptools')
-source=("${_srcname}-${pkgver}.tar.gz"::"https://github.com/Netflix/${_srcname}/archive/v${pkgver}.tar.gz"
- 'vmaf-submodule-sureal'::"git+https://github.com/Netflix/sureal.git#commit=${_sureal_commit}")
-sha256sums=('c9e4fc850f66cf959a36c9603cef26c4298eec20d6c26f9482a355c5753c092d'
- 'SKIP')
-
-prepare() {
- cd "${_srcname}-${pkgver}"
-
- rm -rf sureal
- ln -sf "${srcdir}/vmaf-submodule-sureal" sureal
-}
+source=("${_srcname}-${pkgver}.tar.gz"::"https://github.com/Netflix/${_srcname}/archive/v${pkgver}.tar.gz")
+sha256sums=('926ed538c7d7ae3a36064b87a34094a9d2bee20f7e51a64f8bb275f6c44a8ae3')
build() {
cd "${_srcname}-${pkgver}/python"
@@ -37,35 +26,25 @@ build() {
# waiting for upstream to finish python3 support
# https://github.com/Netflix/vmaf/issues/128
-# https://github.com/Netflix/vmaf/blob/a0a4deeb7cd7b6e5cdd7c40398e6ce3c1498a0d8/resource/doc/VMAF_Python_library.md
+# https://github.com/Netflix/vmaf/blob/fbb9d3ecda8cc2bd80ecbdd63f877825216045be/resource/doc/VMAF_Python_library.md
package() {
cd "${_srcname}-${pkgver}/python"
- local _executables
local _script
- python2 setup.py install --root="$pkgdir" --optimize='1'
+ python2 setup.py install --root="$pkgdir" --skip-build --optimize='1'
# vmaf python2 executables
cd script
- _executables=($(find . -type f -executable))
- for _script in ${_executables[@]}
+ while read -rd '' _script
do
install -D -m755 "$_script" -t "${pkgdir}/usr/bin"
- done
-
- # sureal python2 executable
- cd "${srcdir}/${_srcname}-${pkgver}/sureal/python/script"
- install -D -m755 run_subj.py -t "${pkgdir}/usr/bin"
-
- # sureal python2 modules
- cd "${srcdir}/${_srcname}-${pkgver}/sureal/python/src"
- cp -a sureal "${pkgdir}/usr/lib/python2.7/site-packages"
+ done < <(find . -maxdepth 1 -type f -executable -print0)
# fix shebang on python2 scripts
- for _script in "$pkgdir"/usr/bin/*
+ while read -rd '' _script
do
sed -i '1s/python$/python2/' "$_script"
- done
+ done < <(find "${pkgdir}/usr/bin" -maxdepth 1 -mindepth 1 -type f -print0)
}