summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-03-05 13:11:47 +0000
committerDaniel Bermond2019-03-05 13:11:47 +0000
commit9dd8bd3a843026c7b204f8c6baa35b7e2aa98b97 (patch)
tree6ccafbb9a7306db319bbedd4beed0b9dae54b13b
parent8ce61ff98b62f66e6526f48b03c8d70aa8ba0169 (diff)
downloadaur-9dd8bd3a843026c7b204f8c6baa35b7e2aa98b97.tar.gz
Updated to version 1.3.14
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0deb6fc0cc29..a608aa7acc18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-vmaf
pkgdesc = Perceptual video quality assessment algorithm based on multi-method fusion (python2 implementation)
- pkgver = 1.3.13
+ pkgver = 1.3.14
pkgrel = 1
url = https://github.com/netflix/vmaf/
arch = any
@@ -16,8 +16,8 @@ pkgbase = python2-vmaf
depends = python2-h5py
depends = python2-scikit-image
depends = python2-sureal
- source = vmaf-1.3.13.tar.gz::https://github.com/Netflix/vmaf/archive/v1.3.13.tar.gz
- sha256sums = 926ed538c7d7ae3a36064b87a34094a9d2bee20f7e51a64f8bb275f6c44a8ae3
+ source = vmaf-1.3.14.tar.gz::https://github.com/Netflix/vmaf/archive/v1.3.14.tar.gz
+ sha256sums = e405b9716ea194b851b7d341f670e417ec6a319daec74d3e7bf591b71cbbac1c
pkgname = python2-vmaf
diff --git a/PKGBUILD b/PKGBUILD
index 67e2483fe1bd..77df6d4d4a4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python2-vmaf
_srcname=vmaf
-pkgver=1.3.13
+pkgver=1.3.14
pkgrel=1
pkgdesc='Perceptual video quality assessment algorithm based on multi-method fusion (python2 implementation)'
arch=('any')
@@ -17,7 +17,7 @@ depends=(
)
makedepends=('git' 'python2-setuptools')
source=("${_srcname}-${pkgver}.tar.gz"::"https://github.com/Netflix/${_srcname}/archive/v${pkgver}.tar.gz")
-sha256sums=('926ed538c7d7ae3a36064b87a34094a9d2bee20f7e51a64f8bb275f6c44a8ae3')
+sha256sums=('e405b9716ea194b851b7d341f670e417ec6a319daec74d3e7bf591b71cbbac1c')
build() {
cd "${_srcname}-${pkgver}/python"
@@ -26,7 +26,7 @@ build() {
# waiting for upstream to finish python3 support
# https://github.com/Netflix/vmaf/issues/128
-# https://github.com/Netflix/vmaf/blob/fbb9d3ecda8cc2bd80ecbdd63f877825216045be/resource/doc/VMAF_Python_library.md
+# https://github.com/Netflix/vmaf/blob/fcf8c9e695b16f9f3b43af9a4a0c3fb792fc071a/resource/doc/VMAF_Python_library.md
package() {
cd "${_srcname}-${pkgver}/python"
@@ -36,11 +36,10 @@ package() {
python2 setup.py install --root="$pkgdir" --skip-build --optimize='1'
# vmaf python2 executables
- cd script
while read -rd '' _script
do
install -D -m755 "$_script" -t "${pkgdir}/usr/bin"
- done < <(find . -maxdepth 1 -type f -executable -print0)
+ done < <(find script -maxdepth 1 -mindepth 1 -type f -executable -print0)
# fix shebang on python2 scripts
while read -rd '' _script