summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2018-09-09 01:01:07 -0400
committerGI_Jack2018-09-09 01:01:07 -0400
commitb7a4321b8bdf1f096db6f9ac85aea2409240c785 (patch)
tree965082eb0721f3b001ad95ac035a8581e2bbb487
downloadaur-b7a4321b8bdf1f096db6f9ac85aea2409240c785.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7f48e532850
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Sep 9 05:00:56 UTC 2018
+pkgbase = python2-wappalyzer
+ pkgdesc = Python driver for Wappalyzer, a web application detection utility.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/chorsley/python-Wappalyzer
+ arch = any
+ license = GPLv3
+ depends = python2
+ depends = python2-beautifulsoup4
+ depends = python2-requests
+ depends = python2-nose
+ depends = python2-httpretty
+ source = https://files.pythonhosted.org/packages/34/30/1d686c4de1f3b67286d187488c404afa77fdb14e26f60a9ca5c890c74f05/python-Wappalyzer-0.2.2.tar.gz
+ sha256sums = c09522543b6a76a01bceafed94d465f94a9c2460749b7471544f977c1f697a89
+
+pkgname = python2-wappalyzer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c445a7e423ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+pkgname=python2-wappalyzer
+_pypiname=python-Wappalyzer
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Python driver for Wappalyzer, a web application detection utility."
+arch=('any')
+url="https://github.com/chorsley/python-Wappalyzer"
+license=('GPLv3')
+depends=('python2' 'python2-beautifulsoup4' 'python2-requests' 'python2-nose' 'python2-httpretty')
+makedepends=()
+source=("https://files.pythonhosted.org/packages/34/30/1d686c4de1f3b67286d187488c404afa77fdb14e26f60a9ca5c890c74f05/python-Wappalyzer-${pkgver}.tar.gz")
+sha256sums=('c09522543b6a76a01bceafed94d465f94a9c2460749b7471544f977c1f697a89')
+
+package() {
+ cd "${_pypiname}-${pkgver}"
+ python2 setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}