summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParadoxSpiral2015-06-09 17:06:36 +0000
committerParadoxSpiral2015-06-09 17:06:36 +0000
commit751891acdfc3c4fe8275ab5a924ea0a49a082f22 (patch)
treedaa5b1f3542317c8adfa3e9fe4b1a46541ba75d7
downloadaur-751891acdfc3c4fe8275ab5a924ea0a49a082f22.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c601608b66fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-weberror
+ pkgdesc = Web Error handling and exception catching.
+ pkgver = 0.10.3
+ pkgrel = 2
+ url = http://pylonsproject.org
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-webob
+ depends = python2-tempita
+ depends = python2-simplejson
+ depends = python2-paste>=1.7.1
+ depends = python2-pygments
+ source = http://pypi.python.org/packages/source/W/WebError/WebError-0.10.3.tar.gz
+ md5sums = 84b9990b0baae6fd440b1e60cdd06f9a
+
+pkgname = python2-weberror
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62c522460f0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#Maintainer: Brad Pitcher <bradpitcher@gmail.com>
+#Contributor: David Campbell <davekong@archlinux.us>
+#Contributor: Cilyan Olowen <gaknar@gmail.com>
+#Contributor: Axilleas Pipinellis <axilleas archlinux.gr>
+
+pkgname=python2-weberror
+pkgver=0.10.3
+pkgrel=2
+pkgdesc="Web Error handling and exception catching."
+arch=('any')
+url="http://pylonsproject.org"
+license=('MIT')
+depends=('python2' 'python2-webob' 'python2-tempita' 'python2-simplejson'
+ 'python2-paste>=1.7.1' 'python2-pygments')
+makedepends=('python2-distribute')
+source=(http://pypi.python.org/packages/source/W/WebError/WebError-${pkgver}.tar.gz)
+md5sums=('84b9990b0baae6fd440b1e60cdd06f9a')
+
+package() {
+ cd ${srcdir}/WebError-${pkgver}
+
+ # Fix permission for files in egg-info
+ chmod 0644 WebError.egg-info/*
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
+ sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find $pkgdir -name '*.py')
+}