summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2014-10-06 15:18:32 +0200
committerFlorian Bruhin2015-06-10 22:43:56 +0200
commit2938f71b24fc5f82274b43910b2706b78a9924e2 (patch)
tree96b61e6dfbfa63b99d4cada08cf28f9694512517
parentbf89b44116be61f662b156bc1e0bf6d9e0ae02a7 (diff)
downloadaur-2938f71b24fc5f82274b43910b2706b78a9924e2.tar.gz
python2-websocket-client: Remove tests package. Fixes #4.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--tests-package.patch14
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff83384cea56..ab1dcc027665 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-websocket-client
pkgdesc = Websocket client for Python.
pkgver = 0.18.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/liris/websocket-client
arch = any
license = LGPL
@@ -10,7 +10,9 @@ pkgbase = python2-websocket-client
depends = python2-backports.ssl_match_hostname
depends = python2-six
source = http://pypi.python.org/packages/source/w/websocket-client/websocket-client-0.18.0.tar.gz
+ source = tests-package.patch
sha512sums = 5524271067fd3b89ddbe3ab6cdb2491a1387a54ff569b043a1daffe8b50b0c470c9b6c2671b3d77f2b6261e4125e753410eed818f492e2669df2a84c92bf805a
+ sha512sums = 88f22fac7ad4a333288cd4e2159feada02500b8d3624ef1bc9256a1705d6e03023aee1d5d03330c521dbfe0b2ac4549e49bb6e65ff0b8eeab43c1e01b163e6bc
pkgname = python2-websocket-client
diff --git a/PKGBUILD b/PKGBUILD
index 39f99a793043..29bf2d86de78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python2-websocket-client
pkgver=0.18.0
-pkgrel=1
+pkgrel=2
pkgdesc="Websocket client for Python."
url="https://github.com/liris/websocket-client"
license=('LGPL')
@@ -11,8 +11,15 @@ arch=('any')
depends=('python2>=2.7' 'python2-backports.ssl_match_hostname' 'python2-six')
makedepends=('python2-distribute')
-source=(http://pypi.python.org/packages/source/w/websocket-client/websocket-client-$pkgver.tar.gz)
-sha512sums=('5524271067fd3b89ddbe3ab6cdb2491a1387a54ff569b043a1daffe8b50b0c470c9b6c2671b3d77f2b6261e4125e753410eed818f492e2669df2a84c92bf805a')
+source=(http://pypi.python.org/packages/source/w/websocket-client/websocket-client-$pkgver.tar.gz
+ tests-package.patch)
+sha512sums=('5524271067fd3b89ddbe3ab6cdb2491a1387a54ff569b043a1daffe8b50b0c470c9b6c2671b3d77f2b6261e4125e753410eed818f492e2669df2a84c92bf805a'
+ '88f22fac7ad4a333288cd4e2159feada02500b8d3624ef1bc9256a1705d6e03023aee1d5d03330c521dbfe0b2ac4549e49bb6e65ff0b8eeab43c1e01b163e6bc')
+
+prepare() {
+ cd "$srcdir/websocket-client-$pkgver"
+ patch -p0 -i "$srcdir/tests-package.patch"
+}
build() {
cd "$srcdir/websocket-client-$pkgver"
diff --git a/tests-package.patch b/tests-package.patch
new file mode 100644
index 000000000000..8e13b1f6b151
--- /dev/null
+++ b/tests-package.patch
@@ -0,0 +1,14 @@
+# See https://github.com/liris/websocket-client/issues/112
+--- setup.py.ori 2014-10-06 15:14:40.635658796 +0200
++++ setup.py 2014-10-06 15:14:54.588886934 +0200
+@@ -36,9 +36,8 @@
+ keywords='websockets',
+ scripts=["bin/wsdump.py"],
+ install_requires=install_requires,
+- packages=["tests", "websocket"],
++ packages=["websocket"],
+ package_data={
+- 'tests': ['data/*.txt'],
+ 'websocket': ["cacert.pem"]
+ },
+ )