summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2020-04-08 16:16:13 -0400
committerAdam Goldsmith2020-04-08 16:16:13 -0400
commit435bcf9d6ce534c184ab5fbafe17c70e72891dfa (patch)
tree8e65c9c24392d5cf51fe716c344186a55073cdd8
parent400b3e9ef4e697136aaf29b09ce3bad6d11b611b (diff)
downloadaur-435bcf9d6ce534c184ab5fbafe17c70e72891dfa.tar.gz
Bump version to 0.57.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 047adb51f610..7eb89355b540 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-websocket-client
pkgdesc = Websocket client for Python.
- pkgver = 0.32.0
+ pkgver = 0.57.0
pkgrel = 1
url = https://github.com/liris/websocket-client
arch = any
@@ -8,8 +8,8 @@ pkgbase = python2-websocket-client
makedepends = python2-setuptools
depends = python2>=2.7.9
depends = python2-six
- source = http://pypi.python.org/packages/source/w/websocket-client/websocket_client-0.32.0.tar.gz
- md5sums = b07a897511a3c585251fe2ea85a9d9d9
+ source = https://files.pythonhosted.org/packages/source/w/websocket_client/websocket_client-0.57.0.tar.gz
+ md5sums = 8061820da5e1de26a6a1a6996d4eebd5
pkgname = python2-websocket-client
diff --git a/PKGBUILD b/PKGBUILD
index d0223c953eac..5230022d6f8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
-# Maintainer: Florian Bruhin <archlinux.org@the-compiler.org>
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+# Former Maintainer: Florian Bruhin <archlinux.org@the-compiler.org>
# Contributor: Bruno Galeotti <bgaleotti at gmail dot com>
+_name=websocket_client
pkgname=python2-websocket-client
-pkgver=0.32.0
+pkgver=0.57.0
pkgrel=1
pkgdesc="Websocket client for Python."
url="https://github.com/liris/websocket-client"
@@ -10,17 +12,16 @@ license=('LGPL')
arch=('any')
depends=('python2>=2.7.9' 'python2-six')
makedepends=('python2-setuptools')
-
-source=(http://pypi.python.org/packages/source/w/websocket-client/websocket_client-$pkgver.tar.gz)
-md5sums=('b07a897511a3c585251fe2ea85a9d9d9')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+md5sums=('8061820da5e1de26a6a1a6996d4eebd5')
build() {
- cd "$srcdir/websocket_client-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python2 setup.py build
}
package() {
- cd "$srcdir/websocket_client-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python2 setup.py install --root="$pkgdir" --optimize=1
rm "$pkgdir/usr/bin/wsdump.py" # provided by python3 package
}