summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2014-10-14 08:51:26 +0200
committerFlorian Bruhin2015-06-10 22:43:56 +0200
commit71389bfe52839731df6de3dd672fba8dbcf00b25 (patch)
tree1c963969bc380e194a344a7abc9ccf56ecd67ad6
parent1000e492387b8af31fc9fdacec6f0aca3aab0983 (diff)
downloadaur-71389bfe52839731df6de3dd672fba8dbcf00b25.tar.gz
python2-websocket-client: update to 0.20.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 8 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36d8b045af1b..f1ce198b8b52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-websocket-client
pkgdesc = Websocket client for Python.
- pkgver = 0.18.0
- pkgrel = 3
+ pkgver = 0.20.0
+ pkgrel = 1
url = https://github.com/liris/websocket-client
arch = any
license = LGPL
@@ -9,10 +9,8 @@ pkgbase = python2-websocket-client
depends = python2>=2.7
depends = python2-backports.ssl_match_hostname
depends = python2-six
- source = http://pypi.python.org/packages/source/w/websocket-client/websocket-client-0.18.0.tar.gz
- source = tests-package.patch
- sha512sums = 5524271067fd3b89ddbe3ab6cdb2491a1387a54ff569b043a1daffe8b50b0c470c9b6c2671b3d77f2b6261e4125e753410eed818f492e2669df2a84c92bf805a
- sha512sums = 88f22fac7ad4a333288cd4e2159feada02500b8d3624ef1bc9256a1705d6e03023aee1d5d03330c521dbfe0b2ac4549e49bb6e65ff0b8eeab43c1e01b163e6bc
+ source = http://pypi.python.org/packages/source/w/websocket-client/websocket-client-0.20.0.tar.gz
+ sha512sums = 74a970cf8391b70a61e07887d86eadf3c85a44d6e6877975a7135992e878ff56a1110eef63ea9a4f4b3513cfad109c954c4bcd77c68f741bffd569367f10cfe9
pkgname = python2-websocket-client
diff --git a/PKGBUILD b/PKGBUILD
index 73bae523e47e..e6069c3ed0f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Bruno Galeotti <bgaleotti at gmail dot com>
pkgname=python2-websocket-client
-pkgver=0.18.0
-pkgrel=3
+pkgver=0.20.0
+pkgrel=1
pkgdesc="Websocket client for Python."
url="https://github.com/liris/websocket-client"
license=('LGPL')
@@ -11,15 +11,8 @@ arch=('any')
depends=('python2>=2.7' 'python2-backports.ssl_match_hostname' 'python2-six')
makedepends=('python2-distribute')
-source=(http://pypi.python.org/packages/source/w/websocket-client/websocket-client-$pkgver.tar.gz
- tests-package.patch)
-sha512sums=('5524271067fd3b89ddbe3ab6cdb2491a1387a54ff569b043a1daffe8b50b0c470c9b6c2671b3d77f2b6261e4125e753410eed818f492e2669df2a84c92bf805a'
- '88f22fac7ad4a333288cd4e2159feada02500b8d3624ef1bc9256a1705d6e03023aee1d5d03330c521dbfe0b2ac4549e49bb6e65ff0b8eeab43c1e01b163e6bc')
-
-prepare() {
- cd "$srcdir/websocket-client-$pkgver"
- patch -p0 -i "$srcdir/tests-package.patch"
-}
+source=(http://pypi.python.org/packages/source/w/websocket-client/websocket-client-$pkgver.tar.gz)
+sha512sums=('74a970cf8391b70a61e07887d86eadf3c85a44d6e6877975a7135992e878ff56a1110eef63ea9a4f4b3513cfad109c954c4bcd77c68f741bffd569367f10cfe9')
build() {
cd "$srcdir/websocket-client-$pkgver"
@@ -32,5 +25,4 @@ package() {
rm "$pkgdir/usr/bin/wsdump.py" # provided by python3 package
}
-
# vim: ts=2 sts=2 sw=2 et ft=sh