summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2014-09-22 09:54:43 +0200
committerFlorian Bruhin2015-06-10 22:43:56 +0200
commitfb615566502ffaae5373be8975f3683769a9ff65 (patch)
tree2c8ac0075632a63c578efc42b1d4c30c693b42fa
downloadaur-fb615566502ffaae5373be8975f3683769a9ff65.tar.gz
Add python2-websocket-client
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..444a8fb2f507
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-websocket-client
+ pkgdesc = Websocket client for Python.
+ pkgver = 0.14.1
+ pkgrel = 3
+ url = https://github.com/liris/websocket-client
+ arch = any
+ license = LGPL
+ makedepends = python2-distribute
+ depends = python2>=2.7
+ depends = python2-backports.ssl_match_hostname
+ depends = python2-six
+ source = http://pypi.python.org/packages/source/w/websocket-client/websocket-client-0.14.1.tar.gz
+ sha512sums = 5efb6fdef3560d546aadeadecd4a3f26b08af2086381d92c36b66e956c6ca581187afba8c892fe637483dc1590053c8a7989722f93557d8bd0701560bf980120
+
+pkgname = python2-websocket-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3654f73c86bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Bruno Galeotti <bgaleotti at gmail dot com>
+
+pkgname=python2-websocket-client
+pkgver=0.14.1
+pkgrel=3
+pkgdesc="Websocket client for Python."
+url="https://github.com/liris/websocket-client"
+license=('LGPL')
+arch=('any')
+depends=('python2>=2.7' 'python2-backports.ssl_match_hostname' 'python2-six')
+
+makedepends=('python2-distribute')
+source=(http://pypi.python.org/packages/source/w/websocket-client/websocket-client-$pkgver.tar.gz)
+sha512sums=('5efb6fdef3560d546aadeadecd4a3f26b08af2086381d92c36b66e956c6ca581187afba8c892fe637483dc1590053c8a7989722f93557d8bd0701560bf980120')
+
+build() {
+ cd "$srcdir/websocket-client-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/websocket-client-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ find "$pkgdir" -name "*.py" -exec \
+ sed -i '1s|env python|env python2|' {} \;
+}
+
+
+# vim:ts=2:sw=2:et