summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Moak2015-08-17 19:15:05 -0700
committerScott Moak2015-08-17 19:15:05 -0700
commit798e6e665d9110b021c52d4e798a91a1808caded (patch)
treec52cb39c2bf8ebbe3c59e0266fa80aadeb8aed63
downloadaur-798e6e665d9110b021c52d4e798a91a1808caded.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad9ed07f7da3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-wget
+ pkgdesc = pure python download utility
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://bitbucket.org/techtonik/python-wget
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://bitbucket.org/techtonik/python-wget/get/2.2.tar.gz
+ md5sums = 47cca89b0915d13e4793067f0e634d7c
+
+pkgname = python2-wget
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b97cfa1785b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Scott Moak <scott.moak@mybrainoncode.com>
+
+pkgname=python2-wget
+_hgname=python-wget
+_hgauthor=techtonik
+_hgcommit=9c0e6f40b3c7
+pkgver=2.2
+pkgrel=1
+pkgdesc="pure python download utility"
+arch=(any)
+url="http://bitbucket.org/$_hgauthor/$_hgname"
+license=('GPL')
+depends=('python2')
+makedepends=('python2-setuptools')
+options=(!emptydirs)
+
+source=("https://bitbucket.org/$_hgauthor/$_hgname/get/$pkgver.tar.gz")
+md5sums=('47cca89b0915d13e4793067f0e634d7c')
+
+package() {
+ cd "$srcdir/$_hgauthor-$_hgname-$_hgcommit"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: