summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Petitjean2015-06-08 17:06:56 +0200
committerAlexandre Petitjean2015-06-08 17:06:56 +0200
commit5c4fa0937ba26e1b89a97df4be94ccd54d5ff464 (patch)
tree996487f6b7dad242a837ec3e1b13aac2f3049202
downloadaur-5c4fa0937ba26e1b89a97df4be94ccd54d5ff464.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a69068270f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-ws4py
+ pkgdesc = WebSocket library for Python
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = https://github.com/Lawouach/WebSocket-for-Python
+ arch = any
+ license = BSD
+ makedepends = python2
+ depends = python2
+ optdepends = python2-cherrypy: CherryPy server
+ optdepends = python2-gevent: gevent server
+ optdepends = python2-tornado: Tornado client
+ provides = python2-ws4py
+ conflicts = python2-ws4py-git
+ source = https://pypi.python.org/packages/source/w/ws4py/ws4py-0.3.4.tar.gz
+ md5sums = 6b47e33cbd13f5c134b04f2a44a480ad
+
+pkgname = python2-ws4py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..813a9df518cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexandre Petitjean <alpetitjean at gmail dot com>
+
+pkgname=python2-ws4py
+_pypiname=ws4py
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="WebSocket library for Python"
+arch=('any')
+url="https://github.com/Lawouach/WebSocket-for-Python"
+license=('BSD')
+depends=('python2')
+makedepends=('python2')
+optdepends=('python2-cherrypy: CherryPy server'
+ 'python2-gevent: gevent server'
+ 'python2-tornado: Tornado client')
+conflicts=('python2-ws4py-git')
+provides=('python2-ws4py')
+source=("https://pypi.python.org/packages/source/w/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+md5sums=('6b47e33cbd13f5c134b04f2a44a480ad')
+
+package() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: