summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Leahy2016-06-30 23:41:27 +0100
committerJoshua Leahy2016-06-30 23:41:27 +0100
commitf13adc6d3200b9fa54482451635e6b87f6599a52 (patch)
tree0faeaa6c31a58e425e06c4428491466d706caee4
downloadaur-python2-www-authenticate.tar.gz
Initial commit (v0.9.2)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..500275d812be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-www-authenticate
+ pkgdesc = Parser for WWW-Authenticate headers
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/alexsdutton/www-authenticate
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://pypi.python.org/packages/a7/2d/5567291a8274ef5d9b6495a1ec341394ab68933e2396936755b157f87b43/www-authenticate-0.9.2.tar.gz
+ md5sums = 42557d5d1f8ea37996e666039207d902
+
+pkgname = python2-www-authenticate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14b7725282ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Joshua Leahy <jleahy@gmail.com>
+
+pkgname=python2-www-authenticate
+pkgver=0.9.2
+pkgrel=1
+pkgdesc='Parser for WWW-Authenticate headers'
+arch=(any)
+url='https://github.com/alexsdutton/www-authenticate'
+license=('BSD')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=('https://pypi.python.org/packages/a7/2d/5567291a8274ef5d9b6495a1ec341394ab68933e2396936755b157f87b43/www-authenticate-0.9.2.tar.gz')
+md5sums=('42557d5d1f8ea37996e666039207d902')
+
+build() {
+ cd "${srcdir}/www-authenticate-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/www-authenticate-${pkgver}"
+ python2 setup.py install -O1 --skip-build --root="${pkgdir}"
+}
+