summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2016-08-08 12:41:26 -0700
committerRich Li2016-08-08 12:41:26 -0700
commit35ab476c2c471c564c1c9850faee10e0410e7868 (patch)
treee921996461a8a80924e88bc6de45a2ac7e80c1af
parent46d78e1f4480180a3822669668c6232f155dfb8a (diff)
downloadaur-35ab476c2c471c564c1c9850faee10e0410e7868.tar.gz
Switch from nose to pytest
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cd09c72173a..f365c8a7abfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = python2-xarray
url = http://xarray.pydata.org
arch = any
license = Apache
- checkdepends = python2-nose
+ checkdepends = python2-pytest
makedepends = python2-setuptools
depends = python2-numpy
depends = python2-pandas
diff --git a/PKGBUILD b/PKGBUILD
index 498355fcbbf7..a5baf15aa446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ optdepends=('python2-netcdf4: NetCDF4 support'
'python2-scipy: OPeNDAP support'
'python2-matplotlib: Plotting support')
# 'python2-dask: Enable out-of-core parallel computation') # (doesn't exist in AUR)
-checkdepends=('python2-nose')
+checkdepends=('python2-pytest')
replaces=('python2-xray')
#source=(https://pypi.python.org/packages/source/x/xarray/xarray-"$pkgver".tar.gz)
# I'm using the Github source instead of the PyPI source since the Github source includes the data files used for testing
@@ -30,7 +30,7 @@ build() {
check() {
cd "$srcdir/xarray-$pkgver"
- nosetests2
+ py.test2 xarray
}
package() {