summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2019-01-21 11:30:04 -0800
committerRich Li2019-01-21 11:30:04 -0800
commit372b23d324b09046a4aafc1c67fc737338bc3c8c (patch)
treedda2172f1314cbd16236a36e3c09d54f4e306b44
parent1716f45901b473883359fe04553f9db42406af04 (diff)
downloadaur-372b23d324b09046a4aafc1c67fc737338bc3c8c.tar.gz
Switch to PyPI for source tarball
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e122f139d65..cbc6cd2264c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,10 +16,10 @@ pkgbase = python2-xarray
optdepends = python2-scipy: OPeNDAP support
optdepends = python2-matplotlib: Plotting support
replaces = python2-xray
- source = python2-xarray-0.11.2.tar.gz::https://github.com/pydata/xarray/archive/v0.11.2.tar.gz
- md5sums = 1b7b72632520e334b4bb3684c1b6f7b3
- sha1sums = bed354712d7bf0fc1af68583e6854523bfa28413
- sha256sums = 12659ca2f70c91dc16c5f0cb1b5333a4d749ab869933a0a9a3cf69edffd3d985
+ source = https://files.pythonhosted.org/packages/source/x/xarray/xarray-0.11.2.tar.gz
+ md5sums = 7434e72ef89182aa5eabd58a36f1b357
+ sha1sums = 744376e8fbd737ca65c814288ba435a72ea49fc4
+ sha256sums = af7147152629701f11e424caf8e4fbf5ea1dc2d03ed7a5ca31b83dd64387cfb2
pkgname = python2-xarray
diff --git a/PKGBUILD b/PKGBUILD
index 6672bbe124dc..492365cb7a2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Rich Li <rich@dranek.com>
pkgname='python2-xarray'
+_name=${pkgname#python2-}
pkgver=0.11.2
pkgrel=1
pkgdesc="N-D labeled arrays and datasets in Python"
@@ -17,12 +18,10 @@ optdepends=('python2-netcdf4: NetCDF4 support'
# 'python2-dask: Enable out-of-core parallel computation') # (doesn't exist in AUR)
checkdepends=('python2-pytest')
replaces=('python2-xray')
-#source=(https://pypi.python.org/packages/source/x/xarray/xarray-"$pkgver".tar.gz)
-# I'm using the Github source instead of the PyPI source since the Github source includes the data files used for testing
-source=("$pkgname-$pkgver.tar.gz::https://github.com/pydata/xarray/archive/v$pkgver.tar.gz")
-md5sums=('1b7b72632520e334b4bb3684c1b6f7b3')
-sha1sums=('bed354712d7bf0fc1af68583e6854523bfa28413')
-sha256sums=('12659ca2f70c91dc16c5f0cb1b5333a4d749ab869933a0a9a3cf69edffd3d985')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('7434e72ef89182aa5eabd58a36f1b357')
+sha1sums=('744376e8fbd737ca65c814288ba435a72ea49fc4')
+sha256sums=('af7147152629701f11e424caf8e4fbf5ea1dc2d03ed7a5ca31b83dd64387cfb2')
build() {
cd "$srcdir/xarray-$pkgver"