summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2017-01-28 16:30:17 -0800
committerRich Li2017-01-28 16:30:17 -0800
commit373bc62d69fe5bc8c75a8bae1fb8f2310353b8a3 (patch)
tree7df1ea674d6b4334c7b2e0bebbecd1577b1c1412
parentdf79a320ff4461cbd5d2217d599859bae2f6fc0e (diff)
downloadaur-373bc62d69fe5bc8c75a8bae1fb8f2310353b8a3.tar.gz
Update to version 0.9.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 798696780349..24dd05c5173a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-xarray
pkgdesc = N-D labeled arrays and datasets in Python
- pkgver = 0.8.2
+ pkgver = 0.9.0
pkgrel = 1
url = http://xarray.pydata.org
arch = any
@@ -15,10 +15,10 @@ pkgbase = python2-xarray
optdepends = python2-scipy: OPeNDAP support
optdepends = python2-matplotlib: Plotting support
replaces = python2-xray
- source = python2-xarray-0.8.2.tar.gz::https://github.com/pydata/xarray/archive/v0.8.2.tar.gz
- md5sums = 6862b32f9e43bb870dbf460198e00358
- sha1sums = 31c4cd31196efdc2200f09ac54e824fb30a06eeb
- sha256sums = d8766ea5a7d2349142b08a384552fd2b470126a2de70aa31a183e98b52c354f4
+ source = python2-xarray-0.9.0.tar.gz::https://github.com/pydata/xarray/archive/v0.9.0.tar.gz
+ md5sums = 891595c6c3220a8bceb4be6b91cc2f52
+ sha1sums = f8c014c86cac68abe99e5c3cd715dfabf04a7aa3
+ sha256sums = 05a1ee48cd887ff738c8451fcfb9408103f714df94f16cc944b1c160b4064f95
pkgname = python2-xarray
diff --git a/PKGBUILD b/PKGBUILD
index 1fd09d956c7c..b4864a041693 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rich Li <rich@dranek.com>
pkgname='python2-xarray'
-pkgver=0.8.2
+pkgver=0.9.0
pkgrel=1
pkgdesc="N-D labeled arrays and datasets in Python"
url="http://xarray.pydata.org"
@@ -10,6 +10,7 @@ makedepends=('python2-setuptools')
depends=('python2-numpy' 'python2-pandas')
optdepends=('python2-netcdf4: NetCDF4 support'
'python2-bottleneck: Faster NaN operations'
+ 'python2-pynio: GRIB and other file format support'
'python2-cyordereddict: Speed up most internal operations'
'python2-scipy: OPeNDAP support'
'python2-matplotlib: Plotting support')
@@ -19,9 +20,9 @@ replaces=('python2-xray')
#source=(https://pypi.python.org/packages/source/x/xarray/xarray-"$pkgver".tar.gz)
# I'm using the Github source instead of the PyPI source since the Github source includes the data files used for testing
source=("$pkgname-$pkgver.tar.gz::https://github.com/pydata/xarray/archive/v$pkgver.tar.gz")
-md5sums=('6862b32f9e43bb870dbf460198e00358')
-sha1sums=('31c4cd31196efdc2200f09ac54e824fb30a06eeb')
-sha256sums=('d8766ea5a7d2349142b08a384552fd2b470126a2de70aa31a183e98b52c354f4')
+md5sums=('891595c6c3220a8bceb4be6b91cc2f52')
+sha1sums=('f8c014c86cac68abe99e5c3cd715dfabf04a7aa3')
+sha256sums=('05a1ee48cd887ff738c8451fcfb9408103f714df94f16cc944b1c160b4064f95')
build() {
cd "$srcdir/xarray-$pkgver"
@@ -30,12 +31,12 @@ build() {
check() {
cd "$srcdir/xarray-$pkgver"
- py.test2 xarray
+ pytest2 xarray
}
package() {
cd "$srcdir/xarray-$pkgver"
- python2 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ python2 setup.py install --skip-build --prefix=/usr --root="$pkgdir/" --optimize=1
}
# vim:set ts=2 sw=2 et: