summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2015-11-07 10:25:24 -0700
committerRich Li2015-11-07 10:25:24 -0700
commit7b99cc978a640f32aa97b4e1da6a1ecbb5c38b04 (patch)
treee91526463b1a59e60a96cafe483028140ec31684
parent85518e8402e52bf1969e1c46d65582c7a5dbbea9 (diff)
downloadaur-7b99cc978a640f32aa97b4e1da6a1ecbb5c38b04.tar.gz
Update to version 0.6.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72eb191e580b..68b2b212ac41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-xray
pkgdesc = N-D labeled arrays and datasets in Python
- pkgver = 0.6.0
+ pkgver = 0.6.1
pkgrel = 1
url = https://pypi.python.org/pypi/xray
arch = any
@@ -13,10 +13,11 @@ pkgbase = python2-xray
optdepends = python2-bottleneck: Faster NaN operations
optdepends = python2-cyordereddict: Speed up most internal operations
optdepends = python2-scipy: OPeNDAP support
- source = https://github.com/xray/xray/archive/v0.6.0.tar.gz
- md5sums = b9baf91aa9f6f062eb22bc99b4fe2745
- sha1sums = 3241c32884f4ca78244c1071ab0035e63e8bb557
- sha256sums = 556e3245ff598e2ec789c8212c622060db54f6ebfe1346dbb5439bf704ae5742
+ optdepends = python2-matplotlib: Plotting support
+ source = https://github.com/xray/xray/archive/v0.6.1.tar.gz
+ md5sums = 201ef4249182771a4013e256d330bf96
+ sha1sums = a4ac7c719a76bfa47ab5dec2d63af4468461754b
+ sha256sums = 758baad3c29a9e7f505e55314f3a05ba9cce55c2759433dabd81a58c9436abce
pkgname = python2-xray
diff --git a/PKGBUILD b/PKGBUILD
index 7b4258a16845..35b470fb0c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rich Li <rich@dranek.com>
pkgname='python2-xray'
-pkgver=0.6.0
+pkgver=0.6.1
pkgrel=1
pkgdesc="N-D labeled arrays and datasets in Python"
url="https://pypi.python.org/pypi/xray"
@@ -11,14 +11,16 @@ depends=('python2-numpy' 'python2-pandas')
optdepends=('python2-netcdf4: NetCDF4 support'
'python2-bottleneck: Faster NaN operations'
'python2-cyordereddict: Speed up most internal operations'
- 'python2-scipy: OPeNDAP support')
+ 'python2-scipy: OPeNDAP support'
+ 'python2-matplotlib: Plotting support')
+ # 'python2-dask: Enable out-of-core parallel computation') # (doesn't exist in AUR)
checkdepends=('python2-nose')
#source=(https://pypi.python.org/packages/source/x/xray/xray-"$pkgver".tar.gz)
# I'm using the Github source instead of the PyPI source since the Github source includes the data files used for testing
source=(https://github.com/xray/xray/archive/v"$pkgver".tar.gz)
-md5sums=('b9baf91aa9f6f062eb22bc99b4fe2745')
-sha1sums=('3241c32884f4ca78244c1071ab0035e63e8bb557')
-sha256sums=('556e3245ff598e2ec789c8212c622060db54f6ebfe1346dbb5439bf704ae5742')
+md5sums=('201ef4249182771a4013e256d330bf96')
+sha1sums=('a4ac7c719a76bfa47ab5dec2d63af4468461754b')
+sha256sums=('758baad3c29a9e7f505e55314f3a05ba9cce55c2759433dabd81a58c9436abce')
build() {
cd "$srcdir/xray-$pkgver"