summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Gildas MILLON2016-04-07 10:44:32 +0200
committerPierre-Gildas MILLON2016-04-07 10:44:32 +0200
commita8a5483a323b3fac0e3f7e2ec7c59d10e1e3dd38 (patch)
treef15e293f92301e620295fdde218c4c32777df752
parent384dd5d9b7c6db49e6fbf38d29fab77f9a81bb24 (diff)
downloadaur-a8a5483a323b3fac0e3f7e2ec7c59d10e1e3dd38.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7d96c81eeb8..ad581dd39752 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
-pkgbase = python2-esky
- pkgdesc = keep frozen apps fresh
- pkgver = 0.9.8
+# Generated by mksrcinfo v8
+# Thu Apr 7 08:39:57 UTC 2016
+pkgbase = python2-xattr
+ pkgdesc = Python wrapper for extended filesystem attributes
+ pkgver = 0.8.0
pkgrel = 1
- url = https://pypi.python.org/pypi/esky/
+ url = https://pypi.python.org/pypi/xattr/
arch = any
- license = BSD
+ license = MIT License
makedepends = python2-setuptools
depends = python2
- source = https://pypi.python.org/packages/source/e/esky/esky-0.9.8.tar.gz
+ depends = python2-cffi>=0.4
+ source = https://pypi.python.org/packages/source/e/xattr/xattr-0.8.0.tar.gz
md5sums = 8e09b27df237927b09e59af396c6098c
-pkgname = python2-esky
+pkgname = python2-xattr
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..91dd07001833
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.xz
+xattr-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index fe467be1a6de..8a66a0c31fe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Pierre-Gildas MILLON <pgmillon@gmail.com>
-pkgname=python2-esky
-pkgver=0.9.8
+pkgname=python2-xattr
+pkgver=0.8.0
pkgrel=1
-pkgdesc="keep frozen apps fresh"
+pkgdesc="Python wrapper for extended filesystem attributes"
arch=('any')
-url="https://pypi.python.org/pypi/esky/"
-license=('BSD')
-depends=('python2')
+url="https://pypi.python.org/pypi/xattr/"
+license=(' MIT License')
+depends=('python2' 'python2-cffi>=0.4')
makedepends=('python2-setuptools')
-source=("https://pypi.python.org/packages/source/e/esky/esky-$pkgver.tar.gz")
-md5sums=('8e09b27df237927b09e59af396c6098c')
+source=("https://pypi.python.org/packages/source/x/xattr/xattr-$pkgver.tar.gz")
+md5sums=('23e62facf421f13a555ed47fead58052')
build() {
- cd "${srcdir}/esky-${pkgver}"
+ cd "${srcdir}/xattr-${pkgver}"
python2 setup.py build
}
package() {
- cd "${srcdir}/esky-${pkgver}"
+ cd "${srcdir}/xattr-${pkgver}"
python2 setup.py install --root="${pkgdir}/" --optimize=1
}