summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarry Smith2018-02-14 21:17:41 -0500
committerBarry Smith2018-02-14 21:17:41 -0500
commit664b4d5b3e30af87dc34e0f45ba63f472beb4c87 (patch)
treeeec2a49b3901e4e25ca04bcd0f1ba3290e5cce1a
downloadaur-664b4d5b3e30af87dc34e0f45ba63f472beb4c87.tar.gz
xdot.py is an interactive viewer for graphs. Python2 version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a649f7c18c5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-xdot
+ pkgdesc = Interactive viewer for graphs. Python2 version
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://github.com/jrfonseca/xdot.py
+ arch = any
+ license = LGPL
+ depends = python2-setuptools
+ source = https://pypi.python.org/packages/1e/f7/24050b7f897c547fa18e4e6f0fc744da100b821da69e9f966808c67eb979/xdot-0.6.tar.gz
+ md5sums = a8e5fc5208657b03ad1bd4c46de75724
+
+pkgname = python2-xdot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00d86e8ad819
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Barry Smith <brrtsm@gmail.com>
+pkgname=python2-xdot
+_pyname=xdot
+pkgver=0.6
+pkgrel=1
+pkgdesc="Interactive viewer for graphs. Python2 version"
+url='https://github.com/jrfonseca/xdot.py'
+arch=('any')
+license=('LGPL')
+depends=('python2-setuptools')
+source=(https://pypi.python.org/packages/1e/f7/24050b7f897c547fa18e4e6f0fc744da100b821da69e9f966808c67eb979/${_pyname}-${pkgver}.tar.gz)
+md5sums=('a8e5fc5208657b03ad1bd4c46de75724')
+
+package() {
+ cd "${_pyname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ # Change xdot.py to use python2 instead of python3
+ #sed -i -e '1s:#!/usr/bin/env python:#!/usr/bin/env python2:' "${pkgdir}/usr/lib/python2.7/site-packages/${_pyname}.py"
+
+ # Don't want to overwrite the python3 version
+ rm -rf "${pkgdir}/usr/bin"
+}