summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-06-02 20:22:37 +0200
committerCarsten Teibes2014-06-02 20:22:37 +0200
commit1cf6b0f688b993aae5f7f3aeca17344abb6fae09 (patch)
tree2f77b115b0c386a66fbbc494c84052552a40275d
downloadaur-python2-xlib-svn.tar.gz
[add] python2-xlib-svn
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f2f5dbbe72e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-xlib-svn
+ pkgdesc = A fully functional X client library for Python programs (development version)
+ pkgver = 0.15rc1.r171
+ pkgrel = 1
+ url = http://python-xlib.sourceforge.net/
+ arch = any
+ license = GPL
+ makedepends = subversion
+ depends = python2
+ depends = libx11
+ provides = python2-xlib
+ conflicts = python2-xlib
+ source = python2-xlib-svn::svn+https://svn.code.sf.net/p/python-xlib/code/trunk
+ md5sums = SKIP
+
+pkgname = python2-xlib-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6adee0d8af4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: Thomas Haider <t.haider@deprecate.de>
+
+pkgname=python2-xlib-svn
+pkgver=0.15rc1.r171
+pkgrel=1
+pkgdesc="A fully functional X client library for Python programs (development version)"
+arch=("any")
+url="http://python-xlib.sourceforge.net/"
+license=('GPL')
+depends=('python2' 'libx11')
+makedepends=('subversion')
+provides=('python2-xlib')
+conflicts=('python2-xlib')
+source=($pkgname::"svn+https://svn.code.sf.net/p/python-xlib/code/trunk")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+
+ # get the version directly from package
+ local _ver=$(python2 -ESc "import Xlib; print Xlib.__version_string__")
+ local _rev=$(svnversion | tr -d [A-z])
+ printf "%s.r%s" "$_ver" "$_rev"
+}
+
+build() {
+ cd $pkgname
+
+ python2 setup.py build
+}
+
+package() {
+ cd $pkgname
+
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}