summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimdiels2015-09-16 20:16:26 +0200
committertimdiels2015-09-16 20:17:33 +0200
commite0b4490e1967097f344ac5e199716ad49ade9f93 (patch)
treebb1dd0a562e5be9047ee5b71792858cc1e871c55
downloadaur-e0b4490e1967097f344ac5e199716ad49ade9f93.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eaa2780cb51a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-xlsx2csv
+ pkgdesc = xlsx to csv converter
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://github.com/dilshod/xlsx2csv
+ arch = any
+ license = GPL
+ depends = python
+ options = !emptydirs
+ source = https://github.com/dilshod/xlsx2csv/archive/release/0.7.tar.gz
+ md5sums = 527944a1f4835b4bfb7deec04bc1dd30
+
+pkgname = python2-xlsx2csv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15e7d94ebf4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/Python_Package_Guidelines for more
+# information on Python packaging.
+
+# Maintainer: Tim Diels <youremail@domain.com>
+pkgname=python2-xlsx2csv
+pkgver=0.7
+pkgrel=1
+pkgdesc="xlsx to csv converter"
+arch=(any)
+url="https://github.com/dilshod/xlsx2csv"
+license=('GPL')
+groups=()
+depends=('python')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(https://github.com/dilshod/xlsx2csv/archive/release/$pkgver.tar.gz)
+md5sums=('527944a1f4835b4bfb7deec04bc1dd30') #updpkgsums
+
+package() {
+ cd "$srcdir/xlsx2csv-release-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: