summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Allison2015-07-24 13:26:11 +0100
committerChris Allison2015-07-24 13:26:11 +0100
commite17b56292dd1ddbd21dd8e02e0e5d4dc7bf88a15 (patch)
treedb8722e715502f6c4834d3287e2d2bf25ff5d6fc
downloadaur-e17b56292dd1ddbd21dd8e02e0e5d4dc7bf88a15.tar.gz
initial PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4921c6c7e41e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-xmltv
+ pkgdesc = A Python Module for Reading and Writing XMLTV Files (python2 version)
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://code.google.com/p/python-xmltv/
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ source = https://python-xmltv.googlecode.com/files/python-xmltv-1.3.tar.gz
+ sha256sums = 3f7878790252669b59f252e057ea05cfa71c23962b7d140d8c91c65239410ff8
+
+pkgname = python2-xmltv
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8b0a8c46ef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Chris Allison <chris.allison@hotmail.com>
+
+pkgbase=python2-xmltv
+pkgname=python2-xmltv
+pkgver=1.3
+pkgrel=1
+pkgdesc="A Python Module for Reading and Writing XMLTV Files (python2 version)"
+arch=('any')
+url="https://code.google.com/p/python-xmltv/"
+license=('LGPL')
+makedepends=('python2-setuptools')
+source=("https://python-xmltv.googlecode.com/files/python-xmltv-${pkgver}.tar.gz")
+sha256sums=('3f7878790252669b59f252e057ea05cfa71c23962b7d140d8c91c65239410ff8')
+
+package()
+{
+ depends=("python2")
+
+ cd python-xmltv-${pkgver}
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 README.txt "$pkgdir"/usr/share/doc/$pkgname/README.txt
+ install -Dm644 README.html "$pkgdir"/usr/share/doc/$pkgname/README.html
+}