summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-07-10 12:02:14 -0500
committerLuis Martinez2021-07-11 19:08:08 -0500
commit1d3108ff900488927d12c6e228de40ff9c8e802d (patch)
treeeb4a608cee141286fb89ee590afa28c9a19e94f2
downloadaur-python2-yaml.tar.gz
initial commit based on python-yaml
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..011f43549e28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-yaml
+ pkgdesc = Python bindings for YAML, using fast libYAML library
+ pkgver = 5.4.1.1
+ pkgrel = 1
+ url = https://pyyaml.org/wiki/PyYAML
+ arch = x86_64
+ license = MIT
+ makedepends = python2-setuptools
+ makedepends = cython2
+ depends = python2
+ depends = libyaml
+ source = pyyaml-5.4.1.1.tar.gz::https://github.com/yaml/pyyaml/archive/5.4.1.1.tar.gz
+ sha512sums = bcbe911fbef7e6e8ef8a76293593d4d792dbbf0931a2d031cdeacddf7064b69f958484217bc60d1b7614dcc83ef56cd5c0cd48a0339ab9add623ef70cb2d0a20
+
+pkgname = python2-yaml
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5b7452db02e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Michal Bozon <michal.bozon__at__gmail.com>
+
+pkgname=python2-yaml
+pkgver=5.4.1.1
+pkgrel=1
+pkgdesc='Python bindings for YAML, using fast libYAML library'
+url='https://pyyaml.org/wiki/PyYAML'
+arch=('x86_64')
+license=('MIT')
+depends=('python2' 'libyaml')
+makedepends=('python2-setuptools' 'cython2')
+source=(pyyaml-${pkgver}.tar.gz::https://github.com/yaml/pyyaml/archive/${pkgver}.tar.gz)
+sha512sums=('bcbe911fbef7e6e8ef8a76293593d4d792dbbf0931a2d031cdeacddf7064b69f958484217bc60d1b7614dcc83ef56cd5c0cd48a0339ab9add623ef70cb2d0a20')
+
+build() {
+ (
+ cd pyyaml-$pkgver
+ python2 setup.py --with-libyaml build
+ )
+}
+
+check() {
+ (
+ cd pyyaml-$pkgver
+ python2 -B setup.py test
+ )
+}
+
+package() {
+ cd pyyaml-$pkgver
+ python2 setup.py --with-libyaml install --prefix=/usr --root="${pkgdir}" -O1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -Dm 644 CHANGES README -t "${pkgdir}"/usr/share/doc/${pkgname}
+}
+
+# vim: ts=2 sw=2 et:
+