summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Jaara2015-10-01 22:21:26 +0300
committerJesse Jaara2015-10-01 22:21:26 +0300
commitf397eabfffbcc7222f4088e9a698834cba214870 (patch)
tree188bfb4678d53cc71da4a83fbc4ae01c43445c8c
downloadaur-f397eabfffbcc7222f4088e9a698834cba214870.tar.gz
Import and update python2-youtubedl to AUR4.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf6fb00217ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-youtube-dl
+ pkgdesc = A small command-line program to download videos from YouTube.com and a few more sites
+ pkgver = 2015.08.28
+ pkgrel = 1
+ url = http://rg3.github.io/youtube-dl/
+ arch = any
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2
+ optdepends = ffmpeg: for video post-processing
+ optdepends = rtmpdump: for rtmp streams support
+ source = http://youtube-dl.org/downloads/2015.08.28/youtube-dl-2015.08.28.tar.gz
+ source = http://youtube-dl.org/downloads/2015.08.28/youtube-dl-2015.08.28.tar.gz.sig
+ md5sums = 1bba40e463e71c65436f76b615f4d15e
+ md5sums = SKIP
+
+pkgname = python2-youtube-dl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17fc51895c73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jesse jaara <gmail.com: jesse.jaara>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=python2-youtube-dl
+pkgver=2015.08.28
+pkgrel=1
+pkgdesc="A small command-line program to download videos from YouTube.com and a few more sites"
+arch=('any')
+url="http://rg3.github.io/youtube-dl/"
+license=('custom')
+depends=('python2')
+makedepends=('python2-setuptools')
+optdepends=('ffmpeg: for video post-processing'
+ 'rtmpdump: for rtmp streams support')
+source=(http://youtube-dl.org/downloads/${pkgver}/youtube-dl-${pkgver}.tar.gz
+ http://youtube-dl.org/downloads/${pkgver}/youtube-dl-${pkgver}.tar.gz.sig)
+md5sums=('1bba40e463e71c65436f76b615f4d15e'
+ 'SKIP')
+validpgpkeys=('7D33D762FD6C35130481347FDB4B54CBA4826A18' '428DF5D63EF07494BB455AC0EBF01804BCF05F6B')
+
+
+package() {
+ cd youtube-dl
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python2-youtube-dl/LICENSE"
+
+ rm -r "${pkgdir}/usr/etc"
+ rm -r "${pkgdir}/usr/bin"
+ rm -r "${pkgdir}/usr/share/man"
+ rm -r "${pkgdir}/usr/share/doc"
+}