summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2020-03-30 10:59:19 +0200
committerValHue2020-03-30 10:59:19 +0200
commitb1afa7d081fb73152d26b6e03e0642e9a422310f (patch)
tree62293db91f1d9f8e2461abe3d88b9ae7ed52b28a
downloadaur-b1afa7d081fb73152d26b6e03e0642e9a422310f.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2cf39f0267d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = zbar
+ pkgdesc = Application and library for reading bar codes from various sources
+ pkgver = 0.23
+ pkgrel = 3
+ url = https://github.com/mchehab/zbar
+ arch = x86_64
+ license = LGPL
+ makedepends = gtk3
+ makedepends = imagemagick
+ makedepends = libxv
+ makedepends = v4l-utils
+ makedepends = qt5-x11extras
+ makedepends = python2
+ makedepends = xmlto
+ makedepends = docbook-xsl
+ makedepends = gobject-introspection
+ depends = gdk-pixbuf2
+ depends = python2
+ depends = zbar
+ source = python2-zbar-0.23.tar.gz::https://github.com/mchehab/zbar/archive/0.23.tar.gz
+ sha512sums = bc2667a2a5a5f2e9fd3f39e57bf1d7f860b20a0b5faffc38791d222a6ff0414aff880295ce5ccb92acce7250503f2a7f48ac12651cf82cfb1933b302da26e393
+
+pkgname = python2-zbar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..765b1e391b80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+#
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Marti Raudsepp <marti@juffo.org>
+# Contributor: Radu Andries <admiral0@tuxfamily.org>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+#
+pkgbase="zbar"
+pkgname="python2-zbar"
+pkgver="0.23"
+pkgrel="3"
+pkgdesc="Application and library for reading bar codes from various sources"
+arch=('x86_64')
+url="https://github.com/mchehab/zbar"
+license=('LGPL')
+depends=('gdk-pixbuf2' 'python2' 'zbar')
+makedepends=('gtk3' 'imagemagick' 'libxv' 'v4l-utils' 'qt5-x11extras' 'python2' 'xmlto'
+ 'docbook-xsl' 'gobject-introspection')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/mchehab/zbar/archive/$pkgver.tar.gz")
+sha512sums=('bc2667a2a5a5f2e9fd3f39e57bf1d7f860b20a0b5faffc38791d222a6ff0414aff880295ce5ccb92acce7250503f2a7f48ac12651cf82cfb1933b302da26e393')
+
+build() {
+ cd zbar-$pkgver
+ autoreconf -vfi
+ ./configure --prefix=/usr --with-qt --with-gtk=gtk3 CFLAGS="$CFLAGS -DNDEBUG"
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+
+ cd zbar-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir"/usr/lib/*.so* \
+ "$pkgdir"/usr/lib/*.a \
+ "$pkgdir"/usr/include \
+ "$pkgdir"/usr/lib/pkgconfig \
+ "$pkgdir"/usr/{bin,share} \
+ "$pkgdir"/etc \
+ "$pkgdir"/usr/lib/girepository-1.0
+}
+
+# vim: set ts=4 sw=4 et syn=sh ft=sh: