summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryegorius2016-03-18 23:33:43 +0200
committeryegorius2016-03-18 23:33:43 +0200
commit89933c5a791ac26385edd59cefaa248b17f50214 (patch)
tree0ad437d86791ab0f42da33c65143d45e130b355b
downloadaur-89933c5a791ac26385edd59cefaa248b17f50214.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ce103f5f0b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Mar 18 21:31:20 UTC 2016
+pkgbase = python2-zeroconf
+ pkgdesc = A pure python implementation of multicast DNS service discovery
+ pkgver = 0.17.4
+ pkgrel = 1
+ url = https://github.com/jstasiak/python-zeroconf
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-netifaces
+ depends = python2-six
+ source = https://github.com/jstasiak/python-zeroconf/archive/0.17.4.tar.gz
+ sha256sums = 39ea7752c0032fe22d62f6d38415f7fbd981e43e70f3980a407178b67788ebd0
+
+pkgname = python2-zeroconf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34461aedd82a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Yegorius <yegorius@domic.us>
+
+pkgname=python2-zeroconf
+_srcname=python-zeroconf
+pkgver=0.17.4
+pkgrel=1
+pkgdesc="A pure python implementation of multicast DNS service discovery"
+arch=('any')
+url="https://github.com/jstasiak/python-zeroconf"
+license=('LGPL')
+depends=('python2' 'python2-netifaces' 'python2-six')
+makedepends=('python2-setuptools')
+source=("https://github.com/jstasiak/${_srcname}/archive/${pkgver}.tar.gz")
+sha256sums=('39ea7752c0032fe22d62f6d38415f7fbd981e43e70f3980a407178b67788ebd0')
+
+package() {
+ cd "${srcdir}/${_srcname}-${pkgver}"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+