summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-11-26 16:54:54 +0800
committerYen Chi Hsuan2016-11-26 16:54:54 +0800
commit1c6a8f1454e056f686aeffbe6018653471c82624 (patch)
treef7516b449e2f0c906642fe84b7132c5efe445179
parentebb44c7c72f4197a6bc7621b168f2e958db8464d (diff)
downloadaur-1c6a8f1454e056f686aeffbe6018653471c82624.tar.gz
Fix test errors with testing/filesystem
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--python-2.6-socket-test.patch15
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd18166e441c..01ea320a483b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jul 23 11:39:07 UTC 2016
+# Sat Nov 26 08:54:39 UTC 2016
pkgbase = python26
pkgdesc = Legacy version Python 2.6 of the high-level scripting language
pkgver = 2.6.9
@@ -10,6 +10,7 @@ pkgbase = python26
arch = x86_64
arch = arm
license = PSF
+ checkdepends = net-tools
makedepends = gcc5
makedepends = tk>=8.5.0
depends = db>=4.8
@@ -21,6 +22,7 @@ pkgbase = python26
depends = sqlite3
depends = libffi
optdepends = tk: for IDLE, pynche and modulator
+ optdepends = net-tools: arp, ifconfig and netstat are used in the uuid module
provides = python2=2.6.9
source = http://www.python.org/ftp/python/2.6.9/Python-2.6.9.tar.xz
source = modulator-launcher
@@ -37,6 +39,7 @@ pkgbase = python26
source = python-2.6-ssl-nosslv3.patch
source = python-2.6-tkinter-86.patch
source = python-2.6-whichdb-gdbm-1.9.patch
+ source = python-2.6-socket-test.patch
sha256sums = cae7bb995006ea5b703d9d28446f694894c441fe4bfb95d561c0ac908cd06e41
sha256sums = 9fb0914357b43d4d6d5ea58ef7827cd0f5784792060e776dfa62d6e372b08f8e
sha256sums = e92e300ef7844478c53c37d7c05a27adc714d11106e79537da4b3b8ef039d6cb
@@ -52,6 +55,7 @@ pkgbase = python26
sha256sums = 15bcbd12b6b103db67d828dbf50e22965dc3037297a88616725188b6576d25bb
sha256sums = dbbc72d9c71c065fe3700af4322a130d5c5c459b6ee512f66e7e5eb9e4971171
sha256sums = e0dc2156ca821eaaada49cf5e1e301fc828215288aae648a6e7e4d4da1b38050
+ sha256sums = 8e9d212f8b37c16949fe8707c4300e5721f5b92a40b5f6d0e464929cb7483002
pkgname = python26
diff --git a/PKGBUILD b/PKGBUILD
index f2635c5a57cd..c6e526a6191d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,9 @@ license=('PSF')
url="http://www.python.org/"
depends=('db>=4.8' 'bzip2' 'gdbm' 'openssl' 'zlib' 'expat' 'sqlite3' 'libffi')
makedepends=('gcc5' 'tk>=8.5.0')
-optdepends=('tk: for IDLE, pynche and modulator')
+optdepends=('tk: for IDLE, pynche and modulator'
+ 'net-tools: arp, ifconfig and netstat are used in the uuid module')
+checkdepends=('net-tools')
provides=(python2=${pkgver})
changelog=ChangeLog
source=(http://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz
@@ -29,7 +31,8 @@ source=(http://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz
python-2.6-sqlite-test.patch
python-2.6-ssl-nosslv3.patch
python-2.6-tkinter-86.patch
- python-2.6-whichdb-gdbm-1.9.patch)
+ python-2.6-whichdb-gdbm-1.9.patch
+ python-2.6-socket-test.patch)
sha256sums=('cae7bb995006ea5b703d9d28446f694894c441fe4bfb95d561c0ac908cd06e41'
'9fb0914357b43d4d6d5ea58ef7827cd0f5784792060e776dfa62d6e372b08f8e'
'e92e300ef7844478c53c37d7c05a27adc714d11106e79537da4b3b8ef039d6cb'
@@ -44,7 +47,8 @@ sha256sums=('cae7bb995006ea5b703d9d28446f694894c441fe4bfb95d561c0ac908cd06e41'
'9c01e3bb264eaf6444b76ba6f5265d79bda234b5542fe3d2b478628412186c1e'
'15bcbd12b6b103db67d828dbf50e22965dc3037297a88616725188b6576d25bb'
'dbbc72d9c71c065fe3700af4322a130d5c5c459b6ee512f66e7e5eb9e4971171'
- 'e0dc2156ca821eaaada49cf5e1e301fc828215288aae648a6e7e4d4da1b38050')
+ 'e0dc2156ca821eaaada49cf5e1e301fc828215288aae648a6e7e4d4da1b38050'
+ '8e9d212f8b37c16949fe8707c4300e5721f5b92a40b5f6d0e464929cb7483002')
prepare() {
cd "${srcdir}/Python-${pkgver}"
@@ -81,6 +85,9 @@ prepare() {
# http://bugs.python.org/issue27369
patch -Np0 -i ${srcdir}/python-2.6-expat-2.2.patch
+ # CPython SVN r86565
+ patch -Np1 -i ${srcdir}/python-2.6-socket-test.patch
+
# Ensure that we are using the system copy of various libraries
# (expat, zlib and libffi), rather than copies shipped in the tarball
rm -r Modules/expat
diff --git a/python-2.6-socket-test.patch b/python-2.6-socket-test.patch
new file mode 100644
index 000000000000..090a28524cd4
--- /dev/null
+++ b/python-2.6-socket-test.patch
@@ -0,0 +1,15 @@
+--- Python-2.6.9/Lib/test/test_socket.py.orig 2016-11-08 20:40:24.456911160 +0800
++++ Python-2.6.9/Lib/test/test_socket.py 2016-11-08 20:41:01.106910886 +0800
+@@ -480,7 +480,11 @@
+ # XXX(nnorwitz): http://tinyurl.com/os5jz seems to indicate
+ # it reasonable to get the host's addr in addition to 0.0.0.0.
+ # At least for eCos. This is required for the S/390 to pass.
+- my_ip_addr = socket.gethostbyname(socket.gethostname())
++ try:
++ my_ip_addr = socket.gethostbyname(socket.gethostname())
++ except socket.error:
++ # Probably name lookup wasn't set up right; skip this test
++ return
+ self.assert_(name[0] in ("0.0.0.0", my_ip_addr), '%s invalid' % name[0])
+ self.assertEqual(name[1], port)
+