summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkalekale2021-05-04 17:35:18 +0545
committerkalekale2021-05-04 17:35:18 +0545
commit4483e731144c705efbc16ca4bf3b79fc2dc6802a (patch)
tree6068ed692518020b0997f55db6f5546729a2c479
downloadaur-4483e731144c705efbc16ca4bf3b79fc2dc6802a.tar.gz
0.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d7961b49040
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python3-anilistpy
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/anilistpy/anilistpy
+ arch = i686
+ arch = x86_64
+ license = AGPL2
+ makedepends = python
+ makedepends = rust
+ makedepends = python-pip
+ provides = python3-anilistpy
+ conflicts = python3-anilistpy
+ source = git+https://github.com/anilistpy/anilistpy.git
+ md5sums = SKIP
+
+pkgname = python3-anilistpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53853dc2bc79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: 0kalekale <kalekale.anon@gmail.com> - https://kalekale.ga
+
+pkgname=python3-anilistpy
+pkgver=0.1.0
+pkgrel=1
+pkgdesc=""
+arch=('i686' 'x86_64')
+url="https://github.com/anilistpy/anilistpy"
+license=('AGPL2')
+provides=('python3-anilistpy')
+conflicts=('python3-anilistpy')
+makedepends=('python' 'rust' 'python-pip')
+source=('git+https://github.com/anilistpy/anilistpy.git')
+md5sums=('SKIP')
+
+prepare() {
+ pip3 install setuptools wheel setuptools-rust requests
+}
+
+build() {
+ cd anilistpy
+}
+
+package() {
+ cd anilistpy
+ python3 setup.py install --user
+}