summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2015-06-21 02:20:41 +0000
committerXyne2015-06-21 02:20:41 +0000
commitdf71f39526d7ac9ddda9e815c6a32f70cfe4c617 (patch)
treebe7e2e210c9386514168216bedf35e9972eac14d
downloadaur-df71f39526d7ac9ddda9e815c6a32f70cfe4c617.tar.gz
Initial import.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b53559c4dfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python3-cactus
+ pkgdesc = Interface modules for CACTUS (CADD Group Chemoinformatics Tools and User Services).
+ pkgver = 2012.12
+ pkgrel = 4
+ url = http://xyne.archlinux.ca/projects/python3-cactus
+ arch = any
+ license = GPL
+ depends = python3
+ depends = python-openbabel
+ depends = python3-memoizedb
+ source = http://xyne.archlinux.ca/projects/python3-cactus/src/python3-cactus-2012.12.tar.xz
+ source = http://xyne.archlinux.ca/projects/python3-cactus/src/python3-cactus-2012.12.tar.xz.sig
+ md5sums = e82dd3b1fc6dd07206a329924e6f560c
+ md5sums = c3ecdba4e9a23b2cbc7194c1ea553b79
+ sha512sums = 078517144ab426af206ac0bea1c5a8f1306372065231cc181724bbd47c09090278dd2eb90167ba2a43e7aff755d35592b8eb395d9a453a4e11bbe0f3e3d8ca48
+ sha512sums = f7b81dfccdafcf524a92765b0f08a02295fd248185d7b9f16369d6e6fe0d6f465c3274f7435a5a7a931ec5f438f129cdaf9f736ffc8475c3f2074513ba6dfcc5
+
+pkgname = python3-cactus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0197327323ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer: Xyne <ac xunilhcra enyx, backwards>
+pkgname=python3-cactus
+pkgver=2012.12
+pkgrel=4
+pkgdesc='Interface modules for CACTUS (CADD Group Chemoinformatics Tools and User Services).'
+arch=(any)
+license=(GPL)
+url="http://xyne.archlinux.ca/projects/python3-cactus"
+depends=(python3 python-openbabel python3-memoizedb)
+source=(
+ http://xyne.archlinux.ca/projects/python3-cactus/src/python3-cactus-2012.12.tar.xz
+ http://xyne.archlinux.ca/projects/python3-cactus/src/python3-cactus-2012.12.tar.xz.sig
+)
+sha512sums=(
+ 078517144ab426af206ac0bea1c5a8f1306372065231cc181724bbd47c09090278dd2eb90167ba2a43e7aff755d35592b8eb395d9a453a4e11bbe0f3e3d8ca48
+ f7b81dfccdafcf524a92765b0f08a02295fd248185d7b9f16369d6e6fe0d6f465c3274f7435a5a7a931ec5f438f129cdaf9f736ffc8475c3f2074513ba6dfcc5
+)
+md5sums=(
+ e82dd3b1fc6dd07206a329924e6f560c
+ c3ecdba4e9a23b2cbc7194c1ea553b79
+)
+validpgpkeys=('EC3CBE7F607D11E663149E811D1F0DC78F173680')
+
+package ()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ for script_ in cactus-*
+ do
+ install -Dm755 $script_ "$pkgdir"/usr/bin/$script_
+ done
+}
+
+
+# vim: set ts=2 sw=2 et: