summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2015-06-21 02:20:46 +0000
committerXyne2015-06-21 02:20:46 +0000
commit39bf35de0c45990e5cef8ad205c40eaa9c2d29cb (patch)
tree11a28fc3bbd7b0bb2d580eb60473f4c4b6d6453b
downloadaur-39bf35de0c45990e5cef8ad205c40eaa9c2d29cb.tar.gz
Initial import.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5d4a88e3010
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python3-gpg_batch_sign
+ pkgdesc = A module and stand-alone script for batch-signing files with GPG.
+ pkgver = 2015
+ pkgrel = 1
+ url = http://xyne.archlinux.ca/projects/python3-gpg_batch_sign
+ arch = any
+ license = GPL
+ depends = python3
+ source = http://xyne.archlinux.ca/projects/python3-gpg_batch_sign/src/python3-gpg_batch_sign-2015.tar.xz
+ source = http://xyne.archlinux.ca/projects/python3-gpg_batch_sign/src/python3-gpg_batch_sign-2015.tar.xz.sig
+ md5sums = 5cd9b180671b516a622bf35d03d8b3e8
+ md5sums = f8174f6c1dde9fe3b9ca40013b86af2b
+ sha512sums = 628254107ef2b26ff52ed5d3f07ff7e9149fb1385f326d3190de509e2c2f80e58620c174be4d3d431ad55e092f1ec5a540dbf80de35e8fe2c52d389586bde3bd
+ sha512sums = 43cf6987f06e0f5e66095cf2a4fffb52ef4da179e850a7703e9bf0764c85ee4bec72989183c264389760ab2862db80a420027d0fc9fce542ac612398a669c5e6
+
+pkgname = python3-gpg_batch_sign
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28e7d1b8c79d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+#Maintainer: Xyne <ac xunilhcra enyx, backwards>
+pkgname=python3-gpg_batch_sign
+pkgver=2015
+pkgrel=1
+pkgdesc='A module and stand-alone script for batch-signing files with GPG.'
+arch=(any)
+license=(GPL)
+url="http://xyne.archlinux.ca/projects/python3-gpg_batch_sign"
+depends=(python3)
+source=(
+ http://xyne.archlinux.ca/projects/python3-gpg_batch_sign/src/python3-gpg_batch_sign-2015.tar.xz
+ http://xyne.archlinux.ca/projects/python3-gpg_batch_sign/src/python3-gpg_batch_sign-2015.tar.xz.sig
+)
+sha512sums=(
+ 628254107ef2b26ff52ed5d3f07ff7e9149fb1385f326d3190de509e2c2f80e58620c174be4d3d431ad55e092f1ec5a540dbf80de35e8fe2c52d389586bde3bd
+ 43cf6987f06e0f5e66095cf2a4fffb52ef4da179e850a7703e9bf0764c85ee4bec72989183c264389760ab2862db80a420027d0fc9fce542ac612398a669c5e6
+)
+md5sums=(
+ 5cd9b180671b516a622bf35d03d8b3e8
+ f8174f6c1dde9fe3b9ca40013b86af2b
+)
+validpgpkeys=('EC3CBE7F607D11E663149E811D1F0DC78F173680')
+
+package ()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm755 gpg-batch_sign "$pkgdir"/usr/bin/gpg-batch_sign
+}
+
+
+# vim: set ts=2 sw=2 et: