summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2015-06-21 02:20:52 +0000
committerXyne2015-06-21 02:20:52 +0000
commitd060bc71c6d9e5b118d4c9035f4805121a62cf1e (patch)
tree51799a2ff6eb2fc18aa67ffa0a688fd4ac423c32
downloadaur-d060bc71c6d9e5b118d4c9035f4805121a62cf1e.tar.gz
Initial import.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0de115d17ade
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python3-tabulator
+ pkgdesc = A table formatter class with support for a variety of outputs.
+ pkgver = 2015
+ pkgrel = 1
+ url = http://xyne.archlinux.ca/projects/python3-tabulator
+ arch = any
+ license = GPL
+ depends = python3
+ source = http://xyne.archlinux.ca/projects/python3-tabulator/src/python3-tabulator-2015.tar.xz
+ source = http://xyne.archlinux.ca/projects/python3-tabulator/src/python3-tabulator-2015.tar.xz.sig
+ md5sums = 6e8087b3bd41d45b26da0e29a953fd2a
+ md5sums = 0762ba4a266e5f7663ab8d4aea25600d
+ sha512sums = 6905872b85a4e5acaf0243d58995cd028e75c20ca0f0db2061c3c42c423be51b328f1bc9596e32e2eaa6942ad7d0f46fa787c6809aeca2b7466291a9b4f00669
+ sha512sums = 359c4f6b930b46e749e3ce908e7ccd606da9717c8add61f4f6340dd34487c6a15e02bed728e040bf90bd4b3a72fe452d9b60b4d6970a23924e6929130dc68641
+
+pkgname = python3-tabulator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9df62571c3ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Maintainer: Xyne <ac xunilhcra enyx, backwards>
+pkgname=python3-tabulator
+pkgver=2015
+pkgrel=1
+pkgdesc='A table formatter class with support for a variety of outputs.'
+arch=(any)
+license=(GPL)
+url="http://xyne.archlinux.ca/projects/python3-tabulator"
+depends=(python3)
+source=(
+ http://xyne.archlinux.ca/projects/python3-tabulator/src/python3-tabulator-2015.tar.xz
+ http://xyne.archlinux.ca/projects/python3-tabulator/src/python3-tabulator-2015.tar.xz.sig
+)
+sha512sums=(
+ 6905872b85a4e5acaf0243d58995cd028e75c20ca0f0db2061c3c42c423be51b328f1bc9596e32e2eaa6942ad7d0f46fa787c6809aeca2b7466291a9b4f00669
+ 359c4f6b930b46e749e3ce908e7ccd606da9717c8add61f4f6340dd34487c6a15e02bed728e040bf90bd4b3a72fe452d9b60b4d6970a23924e6929130dc68641
+)
+md5sums=(
+ 6e8087b3bd41d45b26da0e29a953fd2a
+ 0762ba4a266e5f7663ab8d4aea25600d
+)
+validpgpkeys=('EC3CBE7F607D11E663149E811D1F0DC78F173680')
+
+package ()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+
+# vim: set ts=2 sw=2 et: