summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-09-07 21:57:28 +0800
committerYen Chi Hsuan2017-09-07 21:57:28 +0800
commitae7c410c0251879e838d5195476b31c7737f096f (patch)
treef6fc3ae90d521466bcf20292e0e6e1e763d2e362
parent0670662cc687c6ed3d4d14981956a0e0b8762aac (diff)
downloadaur-ae7c410c0251879e838d5195476b31c7737f096f.tar.gz
Bump to 3.3.7rc1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
-rw-r--r--issue27369.patch25
3 files changed, 13 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0df115bc950f..4d6a799b5fec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python33
pkgdesc = Major release 3.3 of the Python high-level programming language
- pkgver = 3.3.6
- pkgrel = 4
+ pkgver = 3.3.7rc1
+ pkgrel = 1
url = http://www.python.org/
arch = i686
arch = x86_64
@@ -24,12 +24,10 @@ pkgbase = python33
optdepends = xz
optdepends = net-tools: arp, ifconfig and netstat are used in the uuid module
options = !makeflags
- source = http://www.python.org/ftp/python/3.3.6/Python-3.3.6.tar.xz
+ source = https://www.python.org/ftp/python/3.3.7/Python-3.3.7rc1.tar.xz
source = python-3.3-ssl-nosslv3.patch
- source = issue27369.patch
- sha256sums = 5226e4bf7a530c3ff2bcde0c94e0e09e59a8bcde0114fe0268bc925bdabb5d3f
+ sha256sums = 98cc1bb74774ce0b4cdb6adcbf183fa757bea3dfd2374d7a76d16698c684f52e
sha256sums = d54bc0ac72218b37c1c2f7a8f03f904a06c2270518a5f3b9e27e54578fe1fb04
- sha256sums = 9defb8e0a18577979816b77c33b16a9f154e332bb3ce554e046c84f0f3998d7e
pkgname = python33
diff --git a/PKGBUILD b/PKGBUILD
index b837bab4e7e5..13a36e2b1355 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
+# Maintainer: Yen Chi Hsuan <yan12125 at gmail>
# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
# Contributor: Rodolphe Breard <packages@what.tf>
# Contributor: Christopher Arndt <chris@chrisarndt.de>
pkgname=python33
-pkgver=3.3.6
-pkgrel=4
+pkgver=3.3.7rc1
+pkgrel=1
_pybasever=3.3
_pymajver=3
pkgdesc="Major release 3.3 of the Python high-level programming language"
@@ -20,12 +21,10 @@ optdepends=('mpdecimal: for decimal'
'net-tools: arp, ifconfig and netstat are used in the uuid module')
checkdepends=('net-tools')
options=('!makeflags')
-source=(http://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz
- python-3.3-ssl-nosslv3.patch
- issue27369.patch)
-sha256sums=('5226e4bf7a530c3ff2bcde0c94e0e09e59a8bcde0114fe0268bc925bdabb5d3f'
- 'd54bc0ac72218b37c1c2f7a8f03f904a06c2270518a5f3b9e27e54578fe1fb04'
- '9defb8e0a18577979816b77c33b16a9f154e332bb3ce554e046c84f0f3998d7e')
+source=(https://www.python.org/ftp/python/${pkgver/rc*/}/Python-${pkgver}.tar.xz
+ python-3.3-ssl-nosslv3.patch)
+sha256sums=('98cc1bb74774ce0b4cdb6adcbf183fa757bea3dfd2374d7a76d16698c684f52e'
+ 'd54bc0ac72218b37c1c2f7a8f03f904a06c2270518a5f3b9e27e54578fe1fb04')
prepare() {
cd "${srcdir}/Python-${pkgver}"
@@ -41,16 +40,12 @@ prepare() {
rm -rf Modules/zlib
rm -rf Modules/_ctypes/{darwin,libffi}*
rm -rf Modules/_decimal/libmpdec
-
- # Tests break with --with-system-expat and Expat 2.2.0
- # https://bugs.python.org/issue27369
- patch -p1 -i ../issue27369.patch
}
build() {
cd "${srcdir}/Python-${pkgver}"
- export CPPFLAGS="-DOPENSSL_NO_SSL3 -I/usr/include/openssl-1.0"
+ export CPPFLAGS="-I/usr/include/openssl-1.0"
export LDFLAGS="-L/usr/lib/openssl-1.0"
./configure --prefix=/usr \
--enable-shared \
@@ -72,7 +67,7 @@ check() {
# make test
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
"${srcdir}/Python-${pkgver}/python" -m test.regrtest -x \
- test_distutils \
+ test_distlib \
test_faulthandler \
test_ftplib \
test_ssl
diff --git a/issue27369.patch b/issue27369.patch
deleted file mode 100644
index 5f0240fa50bc..000000000000
--- a/issue27369.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-
-# HG changeset patch
-# User Martin Panter <vadmium+py@gmail.com>
-# Date 1468460573 0
-# Node ID 1c06e02b968a1645ebaa282fd2c40f6356792251
-# Parent 1c07bd735282009f73cbe4d27ebb7fdbc08f1460# Parent 5b64175c6c2408391782849cd68553e67bdb0989
-Issue #27369: Merge test_pyexpat from 3.2 into 3.3
-
-diff --git a/Lib/test/test_pyexpat.py b/Lib/test/test_pyexpat.py
---- a/Lib/test/test_pyexpat.py
-+++ b/Lib/test/test_pyexpat.py
-@@ -603,11 +603,9 @@ class MalformedInputTest(unittest.TestCa
- # \xc2\x85 is UTF-8 encoded U+0085 (NEXT LINE)
- xml = b"<?xml version\xc2\x85='1.0'?>\r\n"
- parser = expat.ParserCreate()
-- try:
-+ err_pattern = r'XML declaration not well-formed: line 1, column \d+'
-+ with self.assertRaisesRegex(expat.ExpatError, err_pattern):
- parser.Parse(xml, True)
-- self.fail()
-- except expat.ExpatError as e:
-- self.assertEqual(str(e), 'XML declaration not well-formed: line 1, column 14')
-
- class ErrorMessageTest(unittest.TestCase):
- def test_codes(self):