summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoan Blanc2020-05-24 11:16:01 +0200
committerYoan Blanc2020-05-24 11:16:01 +0200
commit5b66f92de67e0777d84a88c06a1ae3d5b2c97b35 (patch)
tree41b3b0cd6a256e218a017ae89df7af0a9da986e6
parent5b8fe428070f817b0c657652bc2bde2bded1ee4f (diff)
downloadaur-5b66f92de67e0777d84a88c06a1ae3d5b2c97b35.tar.gz
add sig, remove ensurepip
Signed-off-by: Yoan Blanc <yoan@dosimple.ch>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5d89abbab91..9930cd0ba3ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python35
pkgdesc = Next generation of the python high-level scripting language
pkgver = 3.5.9
- pkgrel = 2
+ pkgrel = 3
url = https://www.python.org/
arch = i686
arch = x86_64
@@ -21,8 +21,10 @@ pkgbase = python35
optdepends = sqlite
options = !makeflags
source = https://www.python.org/ftp/python/3.5.9/Python-3.5.9.tar.xz
+ source = https://www.python.org/ftp/python/3.5.9/Python-3.5.9.tar.xz.asc
source = nis.patch
sha256sums = c24a37c63a67f53bdd09c5f287b5cff8e8b98f857bf348c577d454d3f74db049
+ sha256sums = SKIP
sha256sums = d5d3412e120f7369518688dfc512d5ba1ae3b054c35c179013ed91a207770e42
pkgname = python35
diff --git a/PKGBUILD b/PKGBUILD
index 72a257ea6963..d24c9eb4c116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Matthew McGinn <mamcgi@gmail.com>
+# Maintainer: Yoan Blanc <yoan@dosimple.ch>
+# Contributor: Matthew McGinn <mamcgi@gmail.com>
# Contributor: Samuel Damashek <samuel.damashek@gmail.com>
# Based on python33 PKGBUILD (g.schulz)
pkgname=python35
pkgver=3.5.9
-pkgrel=2
+pkgrel=3
_pybasever=3.5
pkgdesc="Next generation of the python high-level scripting language"
_github_url="none"
@@ -15,10 +16,12 @@ depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'libnsl' 'libtirpc' 'zlib')
makedepends=('tk' 'sqlite' 'valgrind')
optdepends=('tk: for tkinter' 'sqlite')
options=('!makeflags')
-source=(https://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz nis.patch)
+source=(https://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz{,.asc}
+ nis.patch)
sha256sums=('c24a37c63a67f53bdd09c5f287b5cff8e8b98f857bf348c577d454d3f74db049'
+ 'SKIP'
'd5d3412e120f7369518688dfc512d5ba1ae3b054c35c179013ed91a207770e42')
-
+validgpgkeys=('97FC 712E 4C02 4BBE A48A 61ED 3A5C A953 F73C 700D')
prepare() {
cd "${srcdir}/Python-${pkgver}"
@@ -46,7 +49,8 @@ build() {
--with-valgrind \
--with-system-expat \
--with-dbmliborder=gdbm:ndbm \
- --with-system-ffi
+ --with-system-ffi \
+ --without-ensurepip
make
}