summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Kunze2016-09-10 13:40:12 +0200
committerTobias Kunze2016-09-10 13:40:12 +0200
commitf30e2b9277e84f2a9125ba4253a59b22757e300b (patch)
treea20ab593948a81c73cfabac0d03683ecc770a173
downloadaur-f30e2b9277e84f2a9125ba4253a59b22757e300b.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD73
2 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b369fd4b8bf1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = python36
+ pkgdesc = Major release 3.6 of the Python high-level programming language
+ pkgver = 3.6.0a4
+ pkgrel = 1
+ url = http://www.python.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = tk
+ makedepends = sqlite
+ makedepends = valgrind
+ makedepends = bluez-libs
+ makedepends = mpdecimal
+ makedepends = hardening-wrapper
+ depends = expat
+ depends = bzip2
+ depends = gdbm
+ depends = openssl
+ depends = libffi
+ depends = zlib
+ optdepends = tk: for tkinter
+ optdepends = sqlite
+ options = !makeflags
+ source = http://www.python.org/ftp/python/3.6.0/Python-3.6.0a4.tar.xz
+ sha256sums = 63acec349d20de412682f64c013f7c3374c695430b44e1c0ef12076da1d7fd2c
+
+pkgname = python36
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..440a3a55faee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+pkgname=python36
+pkgver=3.6.0a4
+pkgrel=1
+_pybasever=3.6
+_pymajver=3
+pkgdesc="Major release 3.6 of the Python high-level programming language"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.python.org/"
+depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib')
+makedepends=('tk' 'sqlite' 'valgrind' 'bluez-libs' 'mpdecimal' 'hardening-wrapper')
+optdepends=('tk: for tkinter' 'sqlite')
+options=('!makeflags')
+source=(http://www.python.org/ftp/python/${_pybasever}.0/Python-${pkgver}.tar.xz)
+sha256sums=('63acec349d20de412682f64c013f7c3374c695430b44e1c0ef12076da1d7fd2c')
+# Maintainer: Tobias Kunze <rixx@cutebit.de>
+# Based on python33 script from: Rodolphe Breard <packages@what.tf> and Christopher Arndt <chris@chrisarndt.de>
+# Via the python34 adaption of Raphael Michel <mail@raphaelmichel.de>
+
+prepare() {
+ cd "${srcdir}/Python-${pkgver}"
+
+ # FS#23997
+ sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
+
+ # Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
+ # rather than copies shipped in the tarball
+ rm -rf Modules/expat
+ rm -rf Modules/zlib
+ rm -rf Modules/_ctypes/{darwin,libffi}*
+ rm -rf Modules/_decimal/libmpdec
+}
+
+build() {
+ cd "${srcdir}/Python-${pkgver}"
+
+ CFLAGS=-DOPENSSL_NO_SSL2 ./configure --prefix=/usr \
+ --enable-shared \
+ --with-threads \
+ --with-computed-gotos \
+ --enable-ipv6 \
+ --with-system-expat \
+ --with-dbmliborder=gdbm:ndbm \
+ --with-system-ffi \
+ --with-system-libmpdec \
+ --enable-loadable-sqlite-extensions \
+ --without-ensurepip
+
+ make
+}
+
+package() {
+ cd "${srcdir}/Python-${pkgver}"
+ # altinstall: /usr/bin/pythonX.Y but not /usr/bin/python or /usr/bin/pythonX
+ make DESTDIR="${pkgdir}" altinstall maninstall
+
+ # Avoid conflicts with the main 'python' package.
+ rm "${pkgdir}/usr/lib/libpython${_pymajver}.so"
+ rm "${pkgdir}/usr/share/man/man1/python${_pymajver}.1"
+
+ # Fix FS#22552
+ ln -sf ../../libpython${_pybasever}m.so \
+ "${pkgdir}/usr/lib/python${_pybasever}/config-${_pybasever}m-x86_64-linux-gnu/libpython${_pybasever}m.so"
+
+ # Fix pycairo build
+ ln -sf python${_pybasever}m-config "${pkgdir}/usr/bin/python${_pybasever}-config"
+
+ # Clean-up reference to build directory
+ sed -i "s|$srcdir/Python-${pkgver}:||" "$pkgdir/usr/lib/python${_pybasever}/config-${_pybasever}m-x86_64-linux-gnu/Makefile"
+
+ # License
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}