summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornavigaid2019-10-29 23:50:30 +0800
committernavigaid2019-10-29 23:50:30 +0800
commit64eb6b2d74f46497572540dcce20750ce9ca678a (patch)
tree0be0112ef89a7c759dbf89e7334eedc76e442e3b
downloadaur-64eb6b2d74f46497572540dcce20750ce9ca678a.tar.gz
import ~/archlinux/packages/python/trunk/*
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore3
-rw-r--r--0001-compileall-Fix-ddir-when-recursing.patch57
-rw-r--r--PKGBUILD133
-rw-r--r--dont-make-libpython-readonly.patch13
-rwxr-xr-xgenrebuild6
6 files changed, 254 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a9e78256980
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = python
+ pkgdesc = Next generation of the python high-level scripting language
+ pkgver = 3.7.4
+ pkgrel = 2
+ url = https://www.python.org/
+ arch = x86_64
+ license = custom
+ makedepends = tk
+ makedepends = sqlite
+ makedepends = valgrind
+ makedepends = bluez-libs
+ makedepends = mpdecimal
+ makedepends = llvm
+ makedepends = gdb
+ makedepends = xorg-server-xvfb
+ depends = expat
+ depends = bzip2
+ depends = gdbm
+ depends = openssl
+ depends = libffi
+ depends = zlib
+ depends = libnsl
+ optdepends = python-setuptools
+ optdepends = python-pip
+ optdepends = sqlite
+ optdepends = mpdecimal: for decimal
+ optdepends = xz: for lzma
+ optdepends = tk: for tkinter
+ provides = python3
+ replaces = python3
+ source = https://www.python.org/ftp/python/3.7.4/Python-3.7.4.tar.xz
+ source = https://www.python.org/ftp/python/3.7.4/Python-3.7.4.tar.xz.asc
+ source = dont-make-libpython-readonly.patch
+ source = 0001-compileall-Fix-ddir-when-recursing.patch
+ validpgpkeys = 0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D
+ sha512sums = 71f64668c259f3ed07bd4aa239dbba6cc1b6b0a84d50bbff160664845d7986f757e4d65fca327e62a2d12ba593742ca83a22f7cb6093aff8715ec916c2ba9416
+ sha512sums = SKIP
+ sha512sums = 2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4
+ sha512sums = ebd04c3b6d41321b1f0d439d356e0ce463760db55dc64109854c70d017cf56608aa19de9fc4a21bf840795ff202b4703444f9af8074b661780798c17e03089ff
+
+pkgname = python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0e04299fd70e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+/Python*
diff --git a/0001-compileall-Fix-ddir-when-recursing.patch b/0001-compileall-Fix-ddir-when-recursing.patch
new file mode 100644
index 000000000000..91ebc71f6a22
--- /dev/null
+++ b/0001-compileall-Fix-ddir-when-recursing.patch
@@ -0,0 +1,57 @@
+From 84fdbc156ed424d030686de350fbfc6c3593263f Mon Sep 17 00:00:00 2001
+Message-Id: <84fdbc156ed424d030686de350fbfc6c3593263f.1537028533.git.jan.steffens@gmail.com>
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Sat, 15 Sep 2018 18:22:06 +0200
+Subject: [PATCH] compileall: Fix ddir when recursing
+
+---
+ Lib/compileall.py | 14 +++++++++-----
+ 1 file changed, 9 insertions(+), 5 deletions(-)
+
+diff --git a/Lib/compileall.py b/Lib/compileall.py
+index 72592126d7..70e246fd96 100644
+--- a/Lib/compileall.py
++++ b/Lib/compileall.py
+@@ -45,12 +45,16 @@ def _walk_dir(dir, ddir=None, maxlevels=10, quiet=0):
+ else:
+ dfile = None
+ if not os.path.isdir(fullname):
+- yield fullname
++ yield fullname, ddir
+ elif (maxlevels > 0 and name != os.curdir and name != os.pardir and
+ os.path.isdir(fullname) and not os.path.islink(fullname)):
+ yield from _walk_dir(fullname, ddir=dfile,
+ maxlevels=maxlevels - 1, quiet=quiet)
+
++def _compile_one(file_ddir, *args, **kwargs):
++ file, ddir = file_ddir
++ return compile_file(file, ddir, *args, **kwargs)
++
+ def compile_dir(dir, maxlevels=10, ddir=None, force=False, rx=None,
+ quiet=0, legacy=False, optimize=-1, workers=1,
+ invalidation_mode=py_compile.PycInvalidationMode.TIMESTAMP):
+@@ -79,17 +83,17 @@ def compile_dir(dir, maxlevels=10, ddir=None, force=False, rx=None,
+ if workers is not None and workers != 1 and ProcessPoolExecutor is not None:
+ workers = workers or None
+ with ProcessPoolExecutor(max_workers=workers) as executor:
+- results = executor.map(partial(compile_file,
+- ddir=ddir, force=force,
++ results = executor.map(partial(_compile_one,
++ force=force,
+ rx=rx, quiet=quiet,
+ legacy=legacy,
+ optimize=optimize,
+ invalidation_mode=invalidation_mode),
+ files)
+ success = min(results, default=True)
+ else:
+- for file in files:
+- if not compile_file(file, ddir, force, rx, quiet,
++ for file_ddir in files:
++ if not _compile_one(file_ddir, force, rx, quiet,
+ legacy, optimize, invalidation_mode):
+ success = False
+ return success
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50f073ae9fd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,133 @@
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Jason Chu <jason@archlinux.org>
+
+pkgname=python
+pkgver=3.7.4
+pkgrel=2
+_pybasever=${pkgver%.*}
+pkgdesc="Next generation of the python high-level scripting language"
+arch=('x86_64')
+license=('custom')
+url="https://www.python.org/"
+depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib' 'libnsl')
+makedepends=('tk' 'sqlite' 'valgrind' 'bluez-libs' 'mpdecimal' 'llvm' 'gdb' 'xorg-server-xvfb')
+optdepends=('python-setuptools'
+ 'python-pip'
+ 'sqlite'
+ 'mpdecimal: for decimal'
+ 'xz: for lzma'
+ 'tk: for tkinter')
+provides=('python3')
+replaces=('python3')
+source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc}
+ dont-make-libpython-readonly.patch
+ 0001-compileall-Fix-ddir-when-recursing.patch)
+sha512sums=('71f64668c259f3ed07bd4aa239dbba6cc1b6b0a84d50bbff160664845d7986f757e4d65fca327e62a2d12ba593742ca83a22f7cb6093aff8715ec916c2ba9416'
+ 'SKIP'
+ '2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4'
+ 'ebd04c3b6d41321b1f0d439d356e0ce463760db55dc64109854c70d017cf56608aa19de9fc4a21bf840795ff202b4703444f9af8074b661780798c17e03089ff')
+validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D') # Ned Deily (Python release signing key) <nad@python.org>
+
+prepare() {
+ cd Python-${pkgver}
+
+ # FS#45809
+ patch -p1 -i ../dont-make-libpython-readonly.patch
+
+ # FS#59997
+ patch -p1 -i ../0001-compileall-Fix-ddir-when-recursing.patch
+
+ # https://bugs.python.org/issue34587
+ sed -i -e "s|testCongestion|disabled_&|" Lib/test/test_socket.py
+
+ # FS#23997
+ sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
+
+ # Speed up LTO
+ sed -i -e "s|-flto |-flto=4 |g" configure configure.ac
+
+ # Ensure that we are using the system copy of various libraries (expat, libffi, and libmpdec),
+ # rather than copies shipped in the tarball
+ rm -r Modules/expat
+ rm -r Modules/_ctypes/{darwin,libffi}*
+ rm -r Modules/_decimal/libmpdec
+}
+
+build() {
+ cd Python-${pkgver}
+
+ # PGO should be done with -O3
+ CFLAGS="${CFLAGS/-O2/-O3}"
+
+ # Disable bundled pip & setuptools
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --with-threads \
+ --with-computed-gotos \
+ --enable-optimizations \
+ --with-lto \
+ --enable-ipv6 \
+ --with-system-expat \
+ --with-dbmliborder=gdbm:ndbm \
+ --with-system-ffi \
+ --with-system-libmpdec \
+ --enable-loadable-sqlite-extensions \
+ --without-ensurepip
+
+ # Obtain next free server number for xvfb-run; this even works in a chroot environment.
+ export servernum=99
+ while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
+
+ LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1280x720x24 -ac +extension GLX" -a -n "$servernum" make EXTRA_CFLAGS="$CFLAGS"
+}
+
+check() {
+ # test_gdb is expected to fail with LTO
+ # test_idle, test_tk, test_ttk_guionly segfaults since 3.6.5
+
+ # https://bugs.python.org/issue34022
+ # test_cmd_line_script, test_compileall, test_importlib,
+ # test_multiprocessing_main_handling, test_py_compile, test_runpy
+
+ cd Python-${pkgver}
+
+ # Obtain next free server number for xvfb-run; this even works in a chroot environment.
+ export servernum=99
+ while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
+
+ LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
+ LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1280x720x24 -ac +extension GLX" -a -n "$servernum" \
+ "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_gdb -x test_idle -x test_tk -x test_ttk_guionly \
+ -x test_cmd_line_script -x test_compileall -x test_importlib -x test_multiprocessing_main_handling -x test_py_compile -x test_runpy \
+ -x test_httplib
+}
+
+package() {
+ cd Python-${pkgver}
+
+ # Hack to avoid building again
+ sed -i 's/^all:.*$/all: build_all/' Makefile
+
+ # PGO should be done with -O3
+ CFLAGS="${CFLAGS/-O2/-O3}"
+
+ make DESTDIR="${pkgdir}" EXTRA_CFLAGS="$CFLAGS" install
+
+ # Why are these not done by default...
+ ln -s python3 "${pkgdir}"/usr/bin/python
+ ln -s python3-config "${pkgdir}"/usr/bin/python-config
+ ln -s idle3 "${pkgdir}"/usr/bin/idle
+ ln -s pydoc3 "${pkgdir}"/usr/bin/pydoc
+ ln -s python${_pybasever}.1 "${pkgdir}"/usr/share/man/man1/python.1
+
+ # some useful "stuff" FS#46146
+ install -dm755 "${pkgdir}"/usr/lib/python${_pybasever}/Tools/{i18n,scripts}
+ install -m755 Tools/i18n/{msgfmt,pygettext}.py "${pkgdir}"/usr/lib/python${_pybasever}/Tools/i18n/
+ install -m755 Tools/scripts/{README,*py} "${pkgdir}"/usr/lib/python${_pybasever}/Tools/scripts/
+
+ # License
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/dont-make-libpython-readonly.patch b/dont-make-libpython-readonly.patch
new file mode 100644
index 000000000000..92308bfe97bf
--- /dev/null
+++ b/dont-make-libpython-readonly.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.pre.in b/Makefile.pre.in
+index ce2c0aa..7d6dcf7 100644
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -60,7 +60,7 @@ INSTALL_DATA= @INSTALL_DATA@
+ # Shared libraries must be installed with executable mode on some systems;
+ # rather than figuring out exactly which, we always give them executable mode.
+ # Also, making them read-only seems to be a good idea...
+-INSTALL_SHARED= ${INSTALL} -m 555
++INSTALL_SHARED= ${INSTALL} -m 755
+
+ MKDIR_P= @MKDIR_P@
+
diff --git a/genrebuild b/genrebuild
new file mode 100755
index 000000000000..518cad71a706
--- /dev/null
+++ b/genrebuild
@@ -0,0 +1,6 @@
+#!/bin/bash
+(
+_pyver=$(expac %v python | grep -oP '^[0-9]+\.[0-9]+')
+pacman -Fq /usr/lib/python${_pyver}/ | grep -v archlinuxcn | cut -d / -f 2
+sogrep all libpython${_pyver}m.so
+) | sort -u \ No newline at end of file