summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Kunze2022-03-17 00:44:26 +0100
committerTobias Kunze2022-03-17 00:44:26 +0100
commit7f446d9dd62d2eb44fa7282be3506ce121affa69 (patch)
tree6691366527998205837cd7555a3f3d4107005ed0
parente08cb6c9b619e82ffd4c0a589ce5a21b894b012c (diff)
downloadaur-7f446d9dd62d2eb44fa7282be3506ce121affa69.tar.gz
Revert pip inclusion
Breaks during upgrades when /bin/pip is already in the fs
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 752069e12df6..7919dcebd031 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python38
pkgdesc = Major release 3.8 of the Python high-level programming language
pkgver = 3.8.13
- pkgrel = 1
+ pkgrel = 2
url = https://www.python.org/
arch = i686
arch = x86_64
@@ -19,8 +19,6 @@ pkgbase = python38
optdepends = tk: for tkinter
optdepends = sqlite
provides = python=3.8.13
- provides = python38-pip
- provides = python38-setuptools
source = https://www.python.org/ftp/python/3.8.13/Python-3.8.13.tar.xz
source = https://www.python.org/ftp/python/3.8.13/Python-3.8.13.tar.xz.asc
source = mpdecimal-2.5.1.patch
diff --git a/PKGBUILD b/PKGBUILD
index 9143a1598155..f5d81d8648a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,9 @@
pkgname=python38
pkgver=3.8.13
-pkgrel=1
+pkgrel=2
_pybasever=3.8
_pymajver=3
-_pyminver=8
pkgdesc="Major release 3.8 of the Python high-level programming language"
arch=('i686' 'x86_64')
license=('custom')
@@ -23,7 +22,7 @@ sha256sums=('6f309077012040aa39fe8f0c61db8c0fa1c45136763299d375c9e5756f09cf57'
'SKIP'
'8eb389be1babe03a0231001dc16dd2d69a3ea0fbf6b8c976a580787e7ff1594c')
validpgpkeys=('E3FF2839C048B25C084DEBE9B26995E310250568')
-provides=("python=$pkgver" "python$_pymajver$_pyminver-pip" "python$_pymajver$_pyminver-setuptools")
+provides=("python=$pkgver")
prepare() {
cd "${srcdir}/Python-${pkgver}"
@@ -52,7 +51,8 @@ build() {
--with-system-expat \
--with-dbmliborder=gdbm:ndbm \
--with-system-libmpdec \
- --enable-loadable-sqlite-extensions
+ --enable-loadable-sqlite-extensions \
+ --without-ensurepip
make
}