summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2018-09-21 14:58:10 -0500
committerGötz Christ2018-09-21 15:44:44 -0500
commitf3faf00d20da596d2ca737d6f4a5faf46f241193 (patch)
tree1add3a99638c1ff4910753fc6fc5365374d44fa6
downloadaur-f3faf00d20da596d2ca737d6f4a5faf46f241193.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD33
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe729b9d79c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pytify
+ pkgdesc = A Python CLI application for controlling Spotify.
+ pkgver = 3.5.1
+ pkgrel = 1
+ url = https://github.com/bjarneo/Pytify
+ arch = any
+ license = MIT
+ makedepends = python
+ depends = python-spotipy
+ depends = python-dbus
+ depends = python-prompt_toolkit
+ options = !emptydirs
+ source = pytify-3.5.1.tar.gz::https://github.com/bjarneo/pytify/archive/v3.5.1.tar.gz
+ md5sums = d94046956e9799fc34970297e7f9f020
+
+pkgname = pytify
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..068ec8ad301c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+pytify-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea839a68e00b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: goetzc
+
+pkgname=pytify
+pkgver=3.5.1
+pkgrel=1
+pkgdesc='A Python CLI application for controlling Spotify.'
+arch=(any)
+url='https://github.com/bjarneo/Pytify'
+license=(MIT)
+makedepends=(python)
+depends=(python-spotipy python-dbus python-prompt_toolkit)
+options=(!emptydirs)
+source=($pkgname-$pkgver.tar.gz::https://github.com/bjarneo/${pkgname}/archive/v${pkgver}.tar.gz)
+md5sums=('d94046956e9799fc34970297e7f9f020')
+
+prepare() {
+ cd "Pytify-${pkgver}"
+ sed -i \
+ -e 's/prompt-toolkit==1.0/prompt-toolkit>=1.0/' \
+ -e 's/requests ~= 2.4.3/requests>=2.4.3/' \
+ -e 's/spotipy~=2.3.8/spotipy>=2.4.4/' \
+ setup.py
+}
+
+build() {
+ cd "Pytify-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "Pytify-${pkgver}"
+ python setup.py install --root="$pkgdir/" --skip-build --optimize=1
+}